Zhongshan's profile

New Poster


1 Message

Tue, Sep 29, 2020 10:00 PM

Can't activate the cellular on my apple watch 6

Got my new apple watch 6 yesterday and tried to activate the cellular since then, but failed again and again. When the cellular activation 4-step setup goes to the 4th step, it shows "Uh-oh! Something went wrong......"


Talked to both Xfinity support team and Apple support team on line and by phone, followed their instruction, tried every single possible way, but still can't activate it.


The system of both my phone and watch is up to date. The watch can be paired with my phone without cellular activation, and all functions work well except the cellular. Tried to reset the watch, even deleted and reinstalled the Apple Watch app on my phone. 


Everyone of the support team seemed polite but didn't do anything that makes any sence to solve my problem. I was kicked back and fourth by the phonecall support team and online support team, and then kicked to Apple.

Then I went to Xfinity store in Emeryville, CA, and they tried but it was the same proces that I had tried millions of times, of course they also failed. I thougt they might can do something on their system, but they just did what did by myself at home, then they told me to the neighbouring Apple store.


Went to the Apple store, but was told to book an appointment and wait for a week to get help.


Extreamly frustrated.




Frequent Visitor


5 Messages

7 m ago

We had the same thing happen with our two watches. I was finally able to activate the cellular plan by making sure the wifi was OFF on both my watch and phone. After that, it worked like a charm. It's funny since the direction tell you to make sure you are connected to wifi. 


Hope this helps!



New to the Community?

Start Here