JamesSC's profile

Regular Visitor


1 Message

Fri, Sep 25, 2020 2:00 PM

Can’t activate my Apple Watch 4

Brought two phones and one watch over from Verizon. Customer support was not able to fix my problem. It seems the only one fixing this problem over at Xfinity is @ComcastChrisL. Not sure how to get him. Customer service supposedly put in a ticket. I’m giving this 24hrs. If it is not fixed I’m going back to Verizon. Cheap service obviously comes with it’s drawbacks and customer service seems to be on the top of Xfinty’s list of things the customer must give up.





309 Messages

10 m ago

Is there a store in ur area? You can go online and make an appointment, but some xfinity mobile stores are just letting people walk in.

Frequent Visitor


5 Messages

10 m ago

Hi there. We were having the same problem. We brought over our two phones and two watches from Sprint. Phones activated fine but got stuck in the "uh-oh" error page every time we tried to activate the watches. After spending a few hours reading through a lot of posts on the forum, I stumbled upon one that recommended to turn off the wifi as opposed to keeping it connected as the instructions state.


After performed a factory reset on both watches and setting up as new watches (we did not do this for the phones), we then turned off WiFi on the phones and the watches and tried again. It worked! Watches took about a half hour for the texts to then start showing, but it all seems to be working fine now.


Not sure why they can't have their telephone "support" people understand and share this info. It was a super simple fix for us.


Hope this helps!



New to the Community?

Start Here