FlyingToastr's profile
FlyingToastr
Stamp of Approval
1st Kudo
1st Reply

Regular Visitor

 • 

4 Messages

Sun, Jan 19, 2020 12:00 PM

Cannot stop phone from auto-reconnecting the XFINITY wifi hotspots.

I cannot stop my phone from connecting to XFINITY wifi networks. The option to disable auto-reconnect is gone, and disabling the Hotspot 2.0 setting does not help either. 

 

"Go to Settings > Connections > WiFi > Advanced
2. Toggle Auto-Connect to XFINITY WiFi to off" Does not work because this option has not existed in my phone as of two software updates ago. 

 

"Go to Settings > Connections > WiFi > Advanced > Smart Network Switch
Make sure Smart Network Switch is off" Also does not work. I've tried this both on and off and any time I come home my phone latches onto a Neighbor's XFINITY wifi before I get in range of my apartment unit's gateway. I've had to reconnect to my own wifi 30 times in the past 7 days. 

Samsung Galaxy Note10 SM-N970U purchased directly from Xfinity Mobile

Software build QP1A. 190711.020.N970USQS2BSLA

 

I just wasted 15 minutes proverbially beating my face into a brick wall with a chat agent (and getting increasingly irate with every inane BS easily googled script answer they gave me), trying to have them understand that this issue was not something they could help me solve and rather I just wanted it escalated to the team that codes and QCs the updates. I don't expect a resolution here either. Just need it known and escalated. 

And no, this solution will not help either:
11:45:06 AM XFinity support agent : Alright I will escalate your request to bring the option back and as of now you should eliminate the app.
11:45:23 AM Me: Which app? My phone's OS?
11:45:51 AM XFinity support agent : Xfinity Hotspots.

11:46:31 AM Me: There is no Xfinity Hotspots app installed on my phone
11:48:33 AM MeIt's an Xfinity Mobile phone. The Xfinity hotspot function is baked into the Xfinity custom version of the android Kernel. What you're suggesting is not possible without literally erasing the OS on my phone. (Yes I know I could just root it and that kernel was not necessarily the correct terminology. I was being dramatic)
11:48:34 AM XFinity support agent: http://hotspots.wifi.comcast.com/
11:49:13 AM Me: You sent me a map...

Responses

Frequent Visitor

 • 

6 Messages

1 y ago

Hi @FlyingToastr,

 

Disclaimer: You can try uninstalling the XFINITY WIFI Settings app, but I'm not sure how you can get it again.

 

To try: From your home screen, go to apps, then search for Xfinity Wifi Settings (nothing will show up until you hit Ok go search). The Xfinity Wifi Settings app will show up, open it and from there you should be able to uninstall it.

 

Also, I know this sounds very simple but have you tried just forgetting that ssid from the Manage Networks manu?

 

Let me know if that stops auto reconnect.

GMoGoody

Frequent Visitor

 • 

20 Messages

1 y ago

@FlyingToastr , This just started happening to me as well on my Iphone X. I had disabled Auto Join and even though it's still disabled the phone still joins.  I even tried resetting network settings to default.

I think Xfinity closed the loophole. The reason the service is cheaper is they want people using the hotspots over the cell towers.  This is built into the  Carrier Firmware. Previously they had a bug ot loopholehwere we could prevent the phone from joining. They have since fixed that. 

The only way I now won't join is when I disable WiFi. This auto join drives me nuts becasue I stream media in my car all the time. I constantly lose my signal becasue the phone switches to a business hotspot when I drive by or stopped at a light and then doesn't switch back to Mobile data. You would think their algorithm would use a combination of GPS and movement before doing this switching. 

This is one of the reasons I have just unlocked my phones and leaving for another carrier

Official Employee

 • 

280 Messages

1 y ago

Hello everyone,

 

Thank you for creating the thread and for initiating a useful conversation.  I wanted to find out if you guys had also disabled the Xfinity WiFi Settings app from accessing your phone and location?

 

You can do so by going into Settings>Apps>Show System Apps>Xfinity WiFi Settings, then disable permission to phone and location.  Also, go ahead and disable the Change System Settings option on the app as well.

 

These instructions are for Samsung Galaxy.  Let me know what device/s you are using in order to investigate how this is done on your device in case you haven't located it already.

 

Let me know what results you get.

 

Chris    

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

Regular Visitor

 • 

4 Messages

1 y ago

Xfinity Wifi/Xfinity Wifi settings is not in my phone's system apps. I did not uninstall it at any point either. There is the android Carrier wifi settings which I'm on the verge of force stopping because I am extremely tired of this issue but even that has no special permissions enabled, nor does it require any.

New Poster

 • 

4 Messages

1 y ago

So, uninstalling the Xfinity Wifi Settings stopped the auto-reconnect, but within a few hours my Xfinity mobile service appeared to get throttled. I could not load any content on social media apps or stream even a YouTube video. This persisted even after I restarted my phone.

Once I reinstalled the Xfinity Wifi Settings app, everything continued to work as normal. At work, there are no Xfinity networks nearby, and my wifi is never connected to a network in my office.

Reading through many forums and even reviews in the Android app store, there appears to be an uptick in problems related to Xfinity wifi connections that started in January 2020. That is also when I started having problems and it was also around the time of the latest Android update I received.

It appears that Comcast is now FORCING Xfinity Mobile customers to use hotspots. I was hesitant to use their mobile service for this exact reason. I was assured upon signup that I could disable hotspot autoconnect.

If the problem isn't fixed soon, I'm going back to Verizon.

New Poster

 • 

2 Messages

1 y ago

For iOS devices, check for a profile installed by XFINITY. Removing it will allow you to disable auto join or forget the network, however you may not be able to connect to the password protected XFINITY network automatically. Non-passworded WiFi like xfinitywifi should still work if your device MAC is registered with Xfinity. Connecting to XFINITY WiFi may prompt for a user/pass for your account.

Settings -> General -> Profiles -> XFINITY WiFi -> Remove Profile.

New Poster

 • 

4 Messages

1 y ago

After reinstalling Xfinity Wifi Settings on my S9 with Android 10, I was getting the same problem again. Auto-connect is disabled, but my phone, without asking, is connecting to Xfinitt hotspots. I uninstalled it again and restarted immediately. I havent had any more connectivity issues (see previous post).

However, even without the Xilfinity Wifi Settings app, my phone continues to connect to hotspots without asking. No Xfinity Wifi networks are saved in my phone.

Smart switch is not a feature on S9s.

Not surprised by Xfinitys silence on this...

Frequent Visitor

 • 

8 Messages

1 y ago

I've been having this exact issue as well and it is maddening.

In my own home, my phone will often connect to an Xfinity hotspot with only 1 bar and no service. Nothing will load while connected. I'm having to manually force it to connect to my home network which is saved. Basically, if the phone connects to Xfinity hotspot before it connects to my home network, it will stay connected even though my home network is full strength 5 bars. I do NOT have an Xfinity hotspot in my home as I have my own modem and router.

This needs fixed yesterday. I should be able to CHOOSE when I want to use a hotspot. I'm paying by the gig anyways, so you have no incentive to hold me hostage to your awful network of hotspots, Xfinity.

You need to fix this. We just need an option to NOT auto connect. I've never given my permission for you to autoconnect my phone to your hotspots. This needs to stop. Put an on/off button somewhere. This has me ready to switch carriers.

New Poster

 • 

2 Messages

1 y ago

This issue is plaguing me. Since January 2020. I just wanted to toss my acknowledgment into the thread (will I get an email?). My apartment is densely surrounded by numerous Xfinity hostpots. Countless times per day when I enter my apartment, I'm forced through the manual steps of reconnecting my Xfinity phone to MY OWN Xfinity router in order to control my various smart devices that are on my network. Xfinity tech support said that's just how it is. Unbelievable.

New Poster

 • 

2 Messages

1 y ago

Phones do not auto connect to networks unless they are saved, have a third party application installed, or have some kind of device management profile installed.

For iPhone, standard methods of disabling auto join or forgetting the network, deleting an offending app, or removing a profile will work. I previously posted instructions for removing a profile.

There are too many versions or variations of Android based phones to explain instructions - please search a site like google for how to manage android WiFi profiles, delete apps or limit permissions, or remove android mobile device management profiles. Note that not all apps in android have an icon on the screen; you will need to remove any “hidden” background apps as well.

Frequent Visitor

 • 

8 Messages

1 y ago

@secured2k1 -- I wish I could thumbs-down your post. Clearly you are clueless about this situation. Xfinity has BAKED IN the autoconnect into their latest updates for Xfinity Android devices. So before you say phones only connect to saved networks, you might do your research as you couldn't be more wrong. This is being forced upon us with no ability to disable it as it's baked into the software itself. Do you understand why we are so irritated now??

Regular Visitor

 • 

4 Messages

1 y ago

@Samwathegreat Your reply quite accurately sums up the situation I neglected to elaborate in the original post. I own a gateway and numerous neighbors lease the XB3/XB6 gateways from Comcast which transmit the Xfinity hotspot. Since there is no longer an option to disable auto-reconnect to XFINITY hotspots my phone latches onto those hotspots as I'm walking from my car to my apartment and every time without fail I'm forced to switch it over on my own, and I usually find out after I realize some picture message someone tried to send me never made it and they ask me about it. Even when I'm driving now and using my phone as nav I'm constantly bombarded with the "limited or no internet access. Switch to mobile data?" prompt at the top of the screen as I pass by dozens of useless Xfinity hotspots which if you're the irritable type could be a pretty big safety issue (). To add insult to injury, around late February my phone recieved a software update. Anyone want to guess what issue was NOT addressed in the update and still plagues me to this day?

 

New Poster

 • 

4 Messages

1 y ago

@secured2k1 - you could not be more inaccurate here. I have NEVER voluntarily connected to an xfinity hotspot. There arent even any Xfinity hotspots in my network history. Auto-connect to ALL wifi networks is turned is because that's just smart. As other posters have noted, this is a Forced action from Xfinity. There is a business below my parking garage that has a hotspot. I never connected to a network there and it tries to connect every other day.

This is a specific problem with Xfinity mobile.

The fact that people keep posting and a Comcast rep has not suggested a fix or at least an update that it's being worked on is appalling.

Regular Visitor

 • 

2 Messages

1 y ago

Here is the soulution. You are having this issue because your xFinity gateway is broadcast both "xfinitywifi" and "xfinity" hot spots. That's why you are seeing the hotspots on your phone. "xfinity" is a secure hotspot where as "xfinitywifi" anyone can log into. This is one way that Comcast is blanketing the area with hotspots. You have an option to turn off the hot spots that your gatway is broadcasting and thus will no longer have the issue with connecting to the xfinity hotspots.

 

Logon to your account and click on My Account and then click on Manage Internet and you will find a topic Wifi Public Hotspots. There you can disaable the public hotspots that your gateway is broacasting.

Frequent Visitor

 • 

8 Messages

1 y ago

@wleduc

Myself and several others don't even have an Xfinity gateway. We have our own and prefer it that way.

Anyways, I think you misunderstand the issue. I can be driving down the road listening to music on 4g when the phone randomly decides to connect to the Xfinity hotspot. But since I'm not around long enough to actually use it all it really result in is Google music skipping the current track due to assumed network issues.

Among many other issues. I shouldn't have to constantly reconnect to my full strength wifi because my phone seems to prefer the neighbors XFINITY connection with 1-2 bars over my full strength secured WiFi network.

This is a privacy violation. As far as I'm concerned Xfinity is forcing me to connect to hotspots for which I'm unable to assure the security. It should ALWAYS be my decision to connect to a hotspot. Never my arrogant carrier who thinks they can control me all the while charging inflated rates and having to deal with issues like this.

Why is this still not fixed. We just need an off setting somewhere, Xfinity. What's the problem?

New to the Community?

Start Here