mvenanzi's profile

Bronze Problem Solver

 • 

2.4K Messages

Fri, Jun 4, 2021 6:07 PM

As of today I can't send SMS text messages in airplane mode

Sending SMS text in airplane mode has always worked when connected to wifi. but starting today I get error "Can't Send Message. Turn Off Airplane Node". What's going on?

Responses

DaveO3

Problem Solver

 • 

306 Messages

12 d ago

To send an SMS, MMS, or cellular phone calls you must be connected to XM servers either through a cellular tower or through WiFi Calling. Your phone needs to show either “Xfinity Mobile” or “XM WiFi”. If you are in airplane mode, then your phone must show “XM WiFi”. 

Check your phone to make sure that WiFi Calling is properly enabled, AND that you have a decent enough WiFi internet connection. 

mvenanzi

Bronze Problem Solver

 • 

2.4K Messages

I agree with your first sentence. I have all bars on WIFi icon, I'm at home and cell data is turned off through airplane mode. As I said this has always worked until today. Tried different WIFI servers here and same error. Just tried to make a call on WIFI and get the same error.

mvenanzi

Bronze Problem Solver

 • 

2.4K Messages

I receive emails and can browse the web so I have a valid working WIFI connection

mvenanzi

Bronze Problem Solver

 • 

2.4K Messages

12 d ago

I get the same error when trying to make a call on WIFI. I receive emails and can browse the web so I have a valid working WIFI connection

DaveO3

Problem Solver

 • 

306 Messages

I presume that your screen is showing “XM WiFi” which one would think would mean that you have successfully connected or pinged an XM server?

So they are probably having some sort of server problem. If things don’t go back to normal pretty soon I suggest the following. 

1.) Power off, then power on your phone. Check if you can SMS or call. 
2.) Reset network settings. Check if you can SMS or call. 
3.) Turn off WiFi calling and then enable again. You may have to turn off airplane mode for this. 


Good luck. 

mvenanzi

Bronze Problem Solver

 • 

2.4K Messages

I'm on android and don't have xfinity modem (own my own) never have seen “XM WiFi” on my phone which I've had for 3 yrs. just the radar bars. I was wondering if there were any driod os updates.

DaveO3

Problem Solver

 • 

306 Messages

Go to your browser and enter “WiFi calling on xxxxxx” where xxxxxx is your phone make and model, and you should find additional information for your particular phone. 

DaveO3

Problem Solver

 • 

306 Messages

Check out this link from Verizon:

https://www.verizon.com/support/troubleshooting-wifi-calling-android-video/

mvenanzi

Bronze Problem Solver

 • 

2.4K Messages

The setting on phone are provider specific with xfinity. The settings in that video aren't even available on my phone

mvenanzi

Bronze Problem Solver

 • 

2.4K Messages

12 d ago

New info: friend with Xfinity mobile and droid a state and 2.5 hrs away has same problem. Can't send/recv text or make calls on WIFI only

mvenanzi

Bronze Problem Solver

 • 

2.4K Messages

7 d ago

How things change. Yesterday in settings Airplane mode said if turned on I couldn't make calls or send text. This was true since Friday 6/4. Today in settings Airplane mode no longer says can't make calls or send text and  today I can send SMS and MMS text in airplane mode with wifi on. What is going on?

Official Employee

 • 

8 Messages

I am sorry for the confusion. Enabling Airplane Mode on your mobile device should disable all cell and WiFi functions on your phone. This should block all incoming and outgoing signals. https://comca.st/3pGafuR. I hope this helps. Please let us know if you need help with anything else.

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Solution.tick
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Solution.tick
mvenanzi

Bronze Problem Solver

 • 

2.4K Messages

It's not a problem of confusion on my end, I go into airplane mode then turn on wifi.. This config has worked fine almost all the time for making calls and sending texts. It seems to change every few days lately. As I commented last week every thing went back to normal: in airplane mode and wifi on I could send both types of text and make calls. Today when in airplane mode & wifi enabled I can not send send MMS text or make calls but can browse the web which proves I have an internet connection. Today even when not in airplane mode I can not send MMS text.

New to the Community?

Start Here