dreammonger's profile

Regular Visitor


1 Message

Sat, Sep 19, 2020 11:00 PM

Apple watch Series 4 cellular phone activation



I just switched to xfinity from ATT and I unfortunately the experience has been disappointing. My apple watch cellular phone activation fails in the 4th step and no one at xfinity is able to solve this problem. Can someone please help?




Frequent Visitor


5 Messages

8 m ago

Hi there. We were having the same problem. We brought over our two phones and two watches from Sprint. Phones activated fine but got stuck in the "uh-oh" error page every time we tried to activate the watches. After spending a few hours reading through a lot of posts on the forum, I stumbled upon one that recommended to turn off the wifi as opposed to keeping it connected as the instructions state.


After performed a factory reset on both watches and setting up as new watches (we did not do this for the phones), we then turned off WiFi on the phones and the watches and tried again. It worked! Watches took about a half hour for the texts to then start showing, but it all seems to be working fine now.


Not sure why they can't have their telephone "support" people understand and share this info. It was a super simple fix for us.


Hope this helps!



New to the Community?

Start Here