U

Visitor

 • 

2 Messages

Sat, Sep 10, 2022 3:00 PM

Xfinity app constantly shows "You're already signed in as: username" when log in

I try to log in to xfinity app to set up my modem. After I input my username, password and verification code, the app shows "You're already signed in as: username" and a continue option. When I hit the continue button, the same page appear again. 

I logged in to my account on website and it has no issue.

Any idea how to make the app work? Thanks.

EG

Expert

 • 

95.7K Messages

14 d ago

Concern moved here to the Xfinity App help section for assistance.

Visitor

 • 

2 Messages

14 d ago

I am facing the same issue as well

Visitor

 • 

1 Message

14 d ago

I am also having the same issue

Official Employee

 • 

719 Messages

Hello, @user_081ff5,are you able to let us know if this is happening using different browsers and on multiple devices? 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

2 Messages

13 d ago

Same issue here as well

Visitor

 • 

2 Messages

13 d ago

Has anyone found a solution?

Official Employee

 • 

163 Messages

@labjr001  I'm sorry to hear you're experiencing this issue with the App, is this occurring across multiple devices? Have you deleted and reinstalled the app? 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

1 Message

13 d ago

I am having this issue at well. This sucks. Any solutions?

Official Employee

 • 

163 Messages

@user_a6f3d4 We'd love to get this resolved for you. Have any of the steps in my previous post helped? Please let us know if deleting/reinstalling the app helps, or if this is happening across multiple devices, and if not, which device specifically is seeing the issue. 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

2 Messages

13 d ago

I connected with the customer support agent on chat and they helped with the setup and the app started working after that.

Visitor

 • 

1 Message

13 d ago

Having the exact same problem here.

Official Employee

 • 

116 Messages

@klmnt Thank you for reaching out to the Xfinity Community Forums regarding your login issue with the Xfinity app. Have you attempted any of the steps provided by my colleagues in this thread at this time such as uninstalling and reinstalling the app? Is this happening across multiple devices regarding the app or a particular device?

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick
XfinityKorie

Official Employee

 • 

849 Messages

12 d ago

Hey there, @user_8c563d. I am sorry to hear you are having issues. Have you tried to uninstall/reinstall the app? If you need help with activating the service, we are here for you. 

Visitor

 • 

2 Messages

@XfinityKorie​ i tried uninstalling and reinstalling the app but the problem still persists.

Official Employee

 • 

547 Messages

Seems the history is saved on your phone. can you confirm the type of phone you are using? 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

2 Messages

11 d ago

I have the exact same issue. Any solutions?

Visitor

 • 

1 Message

11 d ago

Same issue here on android. Can't log in to the app and have tried uninstalling and reinstalling, clearing cache and data. Wiped my login credentials and retried from the start but still get stuck in a loop after logging in.

Visitor

 • 

1 Message

11 d ago

Just signed up an account and same issue here.

Official Employee

 • 

151 Messages

@user_abea27, are you still having trouble? Please let us know so we can help you if needed. 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

3 Messages

6 d ago

I am having the same issue with an android phone.  I tried clearing cache on the phone's chrome browser but did not fix.

Official Employee

 • 

227 Messages

@Wesddd have you had a chance to remove and reinstall the app? 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

3 Messages

I had customer support sign in for me on their end and now its working

Visitor

 • 

1 Message

6 d ago

Same issue here. 

Tried with android (firefox and chrome) and apple 13.  No luck - stuck in login loop. 

UPDATE: 

I solved this by calling them and saying "SPEAK TO A REPRESENTATIVE" roughly 50 times and pressing 0 whenever it only gave me one option.

Took 35 minutes and they activated my equipment. Once that was done - I could login to my app and all is now working.  

Absolutely horrible customer experience and guidance.  Why they don't do this in the store when you pick up the equipment is just beyond me.  Why don't they have a help section to handle this is just beyond me. 0/10 would not recommend to anyone. 

(edited)

Visitor

 • 

2 Messages

5 d ago

I'm having the same issue on a Samsung Galaxy S21. I have reinstalled the app twice. I have no problem logging in using a browser. 

forum icon

New to the Community?

Start Here