mrUverse's profile

New Poster


1 Message

Sat, May 23, 2020 11:00 AM

xFi Pods - disappointing

So about 3 weeks ago I ordered Xfinity Gigabit internet service.  I opted to use the free TG3482G gateway.   


First week living with it was mostly positive in terms of perfomance:  speedtest of the ethernet port on the gateway shows I can achieve close to 1 Gbps download.  Wifi speed is typically 400 to 600 Mbps (I think the best I've seen is 700 Mbps) when my computer/tablet/smartphone is within 15 feet of the gateway.  


I have a two-floor house with a 'long-ish' dimension.  The gateway is on the first floor toward one end of the house, while my office room is on the 2nd floor on the other long end of the house.  I was getting about 20 to 60 Mbps wifi speed from my office room.  After two weeks of starting the Xfinity service, I ordered the 3-pack xFi Pods in the hope of speeding up the wifi speed in my office room.


The ordering and shipping process for the Pods went pretty smooth.  Installation (guided by the xFi app) went pretty smoothly as well.  However, after a few days of living with the Pods, I had to remove all of them.  Here is what happened:


- Initially, I installed the 3 pods as follows:  #1 - on the 1st floor about in the middle of the house.  #2 - on 2nd floor about middle of the house.  #3 - in my office room on 2nd floor

- Speed test shows the performance did not improve in my office.  I did confirm (thru xFi app) that my laptop is connected to pod #3 while I was in my office.  I checked the speed with other devices I have (another computer, tablet, smartphone) - same result.  The speed was about what I was getting before (20 to 60 Mbps).


- Next thing I tried is removing pod #3 (in my office).   I see that that laptop in my office switched to pod #2 (midway point on 2nd floor).   Speed went up to about 100 (and occasionally max out at 120) Mbps.  I understand the Pod's spec states it maxes out at 200, so I was OK with the performance I see.


- However, further usage shows another issue: while the speedtest shows fairly consistent 100 Mbps, I start noticing that loading new URLs in my browser could either take a long time, or sometimes with 'hosts unknown' issue for certain sites.   In my experience, this is usally is an DNS issue (ie, cached DNS sites are OK, but uncached DNS sites are slow/unknown).   Now, I do use VPN usually on this laptop (work laptop securely connected to my work's network via vpn).  I am not sure if that is a factor.


- Anyway, after a day or so of this laggy behavior, I removed pod #2 (and pod #1 - since I noticed none of my devices ever connect to #1).   Interestingly, speed test from my office started showing 100 Mbps at times (recall I was seeing only 20 to 60) and DNS issue stopped occurring.


I'm putting the Pods back in the shipping box for now.  


New Poster


1 Message

1 y ago

I'm having a similar issue. It seems to be how Xfinity handles a VPN when using the xFi pods.


I also use a VPN at home and have noticed the VPN disconnects (and subsequently struggles to reconnect) when moving between the gateway and the 1 pod I have connected. It seems to be an issue when going from the 5 GHz band to the 2.4 GHz band (and vice versa), so I figured using the pod would keep everything on the 5 GHz band. My reasoning here is that without the VPN connection it goes between the 2 frequency bands with no disruption, but with the VPN it hangs and eventually drops the connection outright.


I contacted Xfinity about a month ago (through the xFi app) with no response, but this seems to be an issue for many since we're all working from home now, and the VPN vendor says it doesn't appear to be an issue on their end.

New to the Community?

Start Here