Bgrier22's profile

New Poster

 • 

1 Message

Mon, Dec 2, 2019 5:00 PM

Xfi App

I was on the xfi app and was going to buy xfi pods. Instead I went to the store and bought them. Come home, plug them in, try to open the app and it says “can’t load my settings” now. The internet is working, I reset the modem and unplugged it and it still isn’t loading. It worked fine until I plug the pods in now it won’t work. I called xfinity and they can’t help me. Conveniently there is an app outage, funny because it worked fine right up until I plugged the xfi pods in.

This conversation is no longer open for comments or replies and is no longer visible to community members.

Responses

Official Employee

 • 

712 Messages

2 y ago

Hi, we're sorry for this experience. There was a breif period of time on 12/2 where access to xFi was impacted for some customers. Can you please confirm if you have since been able to access and activate your pods?

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Solution.tick

New to the Community?

Start Here