Wbethea13's profile

Regular Visitor


1 Message

Wed, Jul 22, 2020 6:00 AM

XFi app saying I need to upgrade equipment

When I log into the xfi app, it say I have to upgrade my service/equipment before I can use the app, but I have the newest gateway


Regular Visitor


4 Messages

1 y ago

There were a lot of things I tried so I'm not exactly sure which worked; we were troubleshooting quite a few other issues at the time, so I can't remember which did the trick. Some of these were suggestions by Xfinity support and some were just my ideas. This is a new product and it doesn't appear support was properly prepped either, so everyone is kinda learning as they go:

First, I called to have the modem/router "activated". There should be an option on that error page to call and agent and/or have a support text sent to one. 

----Note on above for anyone who cares: there seems to be an issue with proper activation of modems for customers with an xFi plan. Specifically with self-service (I had 4 reps tell me the modem was activated on my account and ready for self-servce. Sadly, it was not). In this call, they ran through the same activation process you would for self-service.

For a VERY weird reason, they will ask you to tell them the SSID and Password over the phone. I wouldn't recommend it, cuz... security, so I would just use the one on the bottom of the modem/router and then change it later. 

The network was working when the call ended, but the app was still stuck on that screen so these steps were done:

- logged out of and back into the xFi app 

- reinstalled the xFi app

- uninstalled the xFi app > installed the Xfinity Mobile app > logged into the Xfinity Mobile app > reinstalled the xFi app (<-- I was automatically logged into this app now)


Sorry for the long response. I hope any of these help and you're not talking to support for 11 hours 🙂

New to the Community?

Start Here