urbanimage5's profile

New Poster

 • 

1 Message

Wed, Jul 22, 2020 11:00 AM

XFi app does not allow login

Trying to use Xfi app for the first time (iPhone SE, iOS 13.5.1). I want to get xFi pods set up and now I'm wishing that the process did not rely on this dumb app. 

 

App does not accept user ID and password that work when I log in to account using computer. App says "Xfinity ID or password you entered was incorrect. Please try again."

If I select "forgot password" and try to reset using Xfi app, I just get the 3 cycling dots for an infinite amount of time and never get to a reset screen.  Tried rebooting phone multiple times. Same end result. Is this app even compatible with iOS 13.5.1?

Responses

Visitor

 • 

1 Message

10 d ago

I have the same problem. I try logging into the app with credentials that DO work on browsers. I get sent a security code and enter it, then see the error message about my login or password being incorrect. This happens over and over again after countless attempts, after deleting and reinstalling the app, and selecting a different default browser (since the login seems to have some relation to that). I have reset my password repeatedly. Nothing has made a difference. 

I get around this by using the internet version of the app but it would be nice to have the app’s features, such as appointment notifications. 

I have not seen any solutions or hacks on the web, nor any company response to this issue. 

I am on an iPhone, iOS 14.5.1. 

This comment has been converted into a post

New to the Community?

Start Here