jjh_decatur's profile

Regular Visitor

 • 

4 Messages

Sun, Sep 29, 2019 3:00 PM

Xfi advanced security blocking certain channels on Pluto tv won't let me watch, what should I do?

I tried to watch the mst3k channel on Pluto tv, it just kept trying to load, other channels worked fine, then I notice advanced security was blocking it. Is there any way to turn off the advanced security for one device, ie Roku?

This conversation is no longer open for comments or replies and is no longer visible to community members.

Responses

Accepted Solution

XfinityHana

Official Employee

 • 

124 Messages

2 y ago

@JeannieB38 @jjh_decatur @tomservo92 @CT13 

 

Pluto TV has been whitelisted for Advanced Security. Please try to use Pluto TV while on your home network and let me know if you're still seeing it get blocked by Advanced Security. 

 

Thanks,

Hana

XfinityHana

Official Employee

 • 

124 Messages

2 y ago

Hi @jjh_decatur 

 

Currently there isn't a way to pause advanced security for just one device, however, I'd like to send this blocked threat for investigation. Could you please let me know, via private message, the MAC for the connected device you were using to stream Pluto TV and the posted time/date of when the blocked threat notification was sent. 

 

To find the device MAC, login to xFi >> Select Devices >> Select the device in question >> Select Device Details >> Note the MAC

 

Thanks,

Hana

Regular Visitor

 • 

5 Messages

2 y ago

I'm having the same issue with the Pluto TV when I stream it to my iOS devices or Windows laptop.  If I reset the router, it works for awhile but then shuts down again.

XfinityHana

Official Employee

 • 

124 Messages

2 y ago

@tomservo92 

 

Thanks for reaching out.  I was able to pull up your account & take a look at the issue you described. I have sent you a private message with additional information. Private messages can be accessed by clicking on the envelope icon in the upper right hand corner of any forums page. Thanks!

Regular Visitor

 • 

5 Messages

2 y ago

Thank you!  It's much appreciated.

New Poster

 • 

1 Message

2 y ago

Hello, were you able to solve this issue, because I am having the trouble with pluto?

Regular Visitor

 • 

5 Messages

2 y ago

No, I'm still waiting on a solution to it.  It's very frustrating!

YorchGtz

Frequent Visitor

 • 

9 Messages

2 y ago

I have seen that indeed content is being intentionally blocked by xFi "Advanced Security" filter.

This is the network response when trying to stream a movie from Pluto on live tv channels:

Location: http://block-prod.xais.apg.comcast.net/warn.html?url=http://siloh-l3.plutotv.net/156b07_Paramount_Pictures/clip/58e28ad2d59f397bb826e934_Stardust_2007/subHD/20180907_081650/hls/hls_1600_keyfile_49.key&token=xxxxxx

 

If you turn off the Advanced Security service, then content will show up immediately (go to your account, xFi Settings, More, Advance, My Services, and then disable advanced security).

 

Although there is no option to exclude individual domains from the filter, this will turn down all the "protection" that they offer (which if you have antivirus and malware installed and updated, you should be fine anyway).

 

Until they allow to fine tune this service, instead of being all-or-nothing, I find it better to keep it off and let me do my own protection tunning at the expense of having content blocked by the provider.

Cheers.

Regular Visitor

 • 

4 Messages

2 y ago

Yes, that is what I ended up having to do. It was also blocking Mario Kart on my daughter's iPhone.

Regular Visitor

 • 

5 Messages

2 y ago

I just turned mine off too.  I guess I'll leave it off until they come up with a resolution.

New Poster

 • 

1 Message

2 y ago

Thanks so much for posting this! I had tried so many things to get Pluto tv to work. I really appreciate you taking the time to help out this non tech person!

Regular Visitor

 • 

5 Messages

2 y ago

So far, it's working.  Thanks for your help!

YorchGtz

Frequent Visitor

 • 

9 Messages

2 y ago

wow thanks Hana!!! I can confirm it is working, and also this is like the first time I see some real solution to a general user base problem. Hope we see more of that in the future.

Cheers.

New to the Community?

Start Here