nocabbages's profile

New Poster


1 Message

Tue, Oct 13, 2020 8:00 AM

Unable to login in to Xfinity Xfi app on Iphone xsmax ios 14.0.1

  1. I Cleared the cache/ turdned off pop blockers etc on chrome and safari, made sure sfari is default browser
  2. Deleted the app and reinstalled
  3. Restarted my Phone
  4. Restarted my Wifi router
  5. Tried to login in using Wifi and Cellular

Nothing works. it logs in to the app but comes back to the login screen ( no sign in button). It stays like that for few mins and the sign in buttn appears. 


I have 2 step verification on so during login process it asks for the sms pin and i am able to put it in and login  properly but the screen on the app doesnt change.


Frequent Visitor


10 Messages

1 m ago

My recent experience leads me to conclude that the use of 2-Step verification is the cause of login failures (to Xfinity applications) with my phone. I am an Xfinity Mobile customer and also have Xfinity Internet, Voice & TV.

From my desktop PC I can log in to anything Xfinity related and there is NO issue when 2-Step verification is turned ON. Logging out and then back in works EVERY time.

From my phone, however, I wish I could say the same. I discovered (when Xfinity Support suggested a password change be tried) that it became temporarily possible to log in to an Xfinity application - even with 2-Step verification active. Unfortunately, this 'solution' was a one shot deal. After logging out, it was no longer possible to log back in... (unless another password change was made).

The behavior of the login failure was consistent, repeated looping. I would enter my username and password (as used with NO error on my PC). Then the code (received via text) was entered and sign in was attempted. At first all looks good, as if the login is working, but then the attempt fails and the screen prompting for credentials reappears (sometimes with text saying that the username and password don't match).

The endless, frustrating failure loop was cured by turning OFF 2-Step verification. I didn't suspect the 2-Step process as the culprit until after trying my login credentials on my wife's phone (which is the same exact type as mine) and was reminded that her Xfinity user account isn't set to use 2-Step.

.Just as Nocabbages message reported, I tried all of the steps listed to no avail. In my case it was with an Android phone but it sure seems that the issue (whatever the root cause) is not just an IPhone affliction. Seems to be something amiss with the way the Xfinity server communicates with the phone.

New to the Community?

Start Here