pyratdame's profile

New Poster

 • 

1 Message

Wed, Feb 12, 2020 7:00 PM

Roku Express Won’t Connect to XFi Pod

Recently received xFi pods. My mother has some at her house and they’ve worked great so I was excited for my own. Set up was easy and didn’t run into any issues.

Until I try to use my Roku Express. It seems to be the only device in the house that has an issue. If the pod is plugged in, Roku says it can’t connect to WiFi. If I unplug it, it connects to the WiFi and works fine. I’ve tried resetting the device, also resetting the WiFi module, and doing some troubleshooting on the Roku itself.

The easiest work around is I just unplug that particular pod but I don’t understand why it doesn’t work with the pod when it should.

Responses

New Poster

 • 

1 Message

1 y ago

I have the exact same issue except I have two Roku Express. One in my living room which works fine and one in my bedroom which worked finr the first couple of days bit know it won't connect. I brought in different devices in the room to see of maybe the signal just wasn't reaching my room but they all worked fine.

New Poster

 • 

1 Message

1 y ago

This is a real issue.  Can anyone help?

New Poster

 • 

1 Message

1 y ago

i dont have a solution, but just got xfinity with xipods and am having the same issue...

New Poster

 • 

1 Message

10 m ago

I have the exact same issue. Roku won’t work with an xFi pod but works just fine when connected to the xFi gateway. What is the deal?

New Poster

 • 

1 Message

9 m ago

Same problem for me. When Roku TV is connected to an XFi Pod, it says it's connected and signal is good, but any apps like Netflix or Hulu say no connection. Unplug the Pod, and TV works fine. Does Comcast monitor this forum?

New to the Community?

Start Here