JiveDude2's profile

Frequent Visitor

 • 

7 Messages

Tue, Feb 25, 2020 1:00 PM

Port forwarding in xFi has the right device but the wrong reserved IP address

Trying to add a Port forward through the xfi website as it wont allow anymore directly from the router.

 

And even  though i know the ip address of the destination computer, i have to select the "device" as im not smart enough to know about computers. sigh. Guess what selecting the right device, gives the wrong reserved Ip address.

Looking up the device in the devices section after 10 additional clicks it has the correct ip address associated with it. Retrying multiple times, refreshing, deleting adding again, it sticks to the wrong ip address. Whats the secret sauce here to get an input field for an ip address in the portforwarding tool, or just let me configure it by hand in the router/gateway.

Responses

New Poster

 • 

3 Messages

1 y ago

I have the same issue. Have you found any solution?

 

 

Frequent Visitor

 • 

7 Messages

1 y ago

Yes, a workaround i found was to go in your router software itself.

Assign the device the fixed ip the xfi software believes it has on the web interface and then setup the port forward again.

 

Its a hassle to go into two different places, but that should work.

 

Greetings

 

New Poster

 • 

1 Message

1 y ago

Another way is to forget the device that has the wrong IP.

1 Message

3 m ago

This issue still has not been resolved.

The true router settings are not accessible to the customer. There is a browser UI that displays “settings” but really it’s an API that connects to your router. The first time the router distributes an IP to a network card, a database stores the hostname and IP by the MAC address. When you access the browser UI it accesses the database which returns the data associated to the Mac Address. It doesn’t seem that the database gets updated when the router makes changes. Therefore, if the IP address does change because the router does what it’s supposed to, the UI displays the wrong data in your settings (I.e. port forwarding). 

As previously mentioned you can set the IP of the device manually to what the UI shows. 

FYI: If I disconnect the device it doesn’t show in the not connected section so that’s not an option for everyone.

Don’t waste your time contacting support. They do not understand the issue and will get you to try everything in every KB article they have, ultimately with no resolution. 

I am sure if you change routers or do a complete reset it will temporarily fix the issue but it will happen again until they fix this.

**Edit After digging deeper I was able to access the router directly by 

typing in the IP of the gateway into a browser. It appears that the issue is with the firmware. It seems to lock in certain Mac Addresses and will not let you manage that device when it does. But I was able to fix the issue. I will detail the resolution for future reference.

Solution:

Step 1

Log into your gateway via a web browser.


Your gateway may differ. But here are typical settings:

Https://10.0.0.1

Default user: admin

Default password: password

Step 2

Remove IP Reservation.

On the left pane click Connected Devices.

In the main pane click the edit button next to the device that has the wrong IP.

Select the radio button for DHCP.

Click SAVE.

Step 3

Release and Renew your IP on the device that is showing the wrong IP.

On a Windows PC for example:

Click Start

Type cmd

Press enter

Type ipconfig /release

Press enter

Type ipconfig /renew

Press enter.

Issue resolved.

**

(edited)

New to the Community?

Start Here