hekride's profile

New Poster

 • 

1 Message

Sat, Jun 6, 2020 6:00 AM

Pods Overheating

Whey do the pods get so hot?? It seems like they over heat causing them to go offline and lose connection. It is kind of scary how hot they get.

Responses

Official Employee

 • 

131 Messages

1 y ago

Hi, @hekride  I am sorry that your pods are getting hot. If you have had the pods less than 30 days you can return for a full refund. The pods also come with a 1 yr warranty as well.

 

To get a full refund, you'll need to return your Pods within 30 days. Pods can be exchanged within one year under the hardware warranty. To initiate a return or exchange, visit xfinity.com/xfipodsreturns.

New Poster

 • 

1 Message

1 y ago

But are the pods supposed to get that hot? I unplugged them to cool off. Are you saying they need to be replaced?

New Poster

 • 

1 Message

1 y ago

Did you ever get a response? I am having the same issue.

New Poster

 • 

2 Messages

1 y ago

Is this typical? You offer a refund, does that mean it isn’t? Is it dangerous?

New Poster

 • 

2 Messages

1 y ago

One of my pods stopped working; I checked it and it’s pretty hot. Doesn’t seem good.

New Poster

 • 

1 Message

1 y ago

We are having the same problem. Pods have been working fine for over a year; lately they've been overheating and going offline daily.

New Poster

 • 

1 Message

1 y ago

I'm having the same issue. Trying to obtain a refund for this. My daughter burned her fingers when she touched them bc they were so hot. I bought the 3 pack and had them installed correctly. We experienced the exact same thing where they would overheat, and appear to shutdown causing a loss in internet connection. Once I removed them all I haven't had any further internet connection loss since.
mjboh3

Frequent Visitor

 • 

8 Messages

9 m ago

Similar issue for me. I've had the pods pretty much since they came out. One of my pods started acting flaky (including falling offline entirely with the white LED flashing.) Upon touching the pod, it felt abnormally hot. I would unplug, let it cool down, and plug it back in. Would work for a while, but then get flaky again. 

 

As luck would have it, I have only been using 2 of the 3 pods in the pack, so I was able to swap out the overheating pod. But this doesn't bode well for the product. 

New Poster

 • 

1 Message

9 m ago

I’m having the same problem. I’ve tried all the troubleshooting steps and swapped pods. It works for a while and then crashes again. I also have had them since they came out. They’ve worked fine up until a month or two ago. Now they’re very unreliable.

New Poster

 • 

1 Message

9 m ago

Here to say I'm in the same boat as everyone else here. I've had the pods since they came out and they're overheating now. I really wish that they actually sponsored the pods...they were pretty expensive to add on to get their internet to work in my house and now they're malfunctioning. 

New Poster

 • 

2 Messages

7 m ago

Heat???

New Poster

 • 

2 Messages

7 m ago

Did we ever get any resolution on this as far heat?

New Poster

 • 

1 Message

7 m ago

Still looking for complete answer.  Is this a problem with the Pods, started having this same issue about 30 days ago and now every couple of days I need to unplug the pods, they are extremely warm and then I have to plug them back in and everything comes back.  Really wish someone answered the question to understand if there is an issue with these devices or if this is some type of IOS issue that needs to be addressed.

Visitor

 • 

1 Message

3 m ago

My 3 pods are leaving burn marks on my wall. Was told by a rep he’s never heard of this issue. What a joke. I’m canceling service with Comcast over the headache of this

(edited)

New Poster

 • 

2 Messages

1 m ago

Same issue here.   There is constantly breaks in service.  I didn't know that is was because of over heating until my wife pulled one from the wall because it was so hot and was worried it was a fire hazard.   Has Xfinity provided any type of answer?  Has anyone gotten replacements?

EG

Expert

 • 

87.2K Messages

@Mikfol23 

Please create a new topic of your own here on this board detailing your issue. Thanks. Year old dead thread now being closed.

New to the Community?

Start Here