U

Visitor

 • 

2 Messages

Fri, Jul 30, 2021 7:30 PM

My Xfinity account website/app is not loading correctly

I’m a new customer since Sunday, 7/25/21 and it’s been almost a week I haven’t able to activate my service. The first day I was able to login and view my account using my personal cellular service because my WiFi wasn’t activated. A tech came by on Wednesday to install everything and told me that I was able to do the rest on my phone after certain minutes.Then I spoke to the Rep and they said I need to login using a device with better data speed to load it up. Well, I use three devices with good internet connection including my own phone and still kept saying “Sorry page not loading correctly“ on every device. So I cleared my website cache and used different browsers from what I was researching, still didn’t work. I tried the app and It takes me right back to the login home page whenever I enter it in. My password is correct and everything. I even changed it twice to make sure that wasn’t the problem. Is the Xfinity website broken or something because it’s been this long and I still haven’t gotten my internet started!

Responses

XfinityAmir

Official Employee

 • 

6.5K Messages

2 m ago

Hi user_fd3858, thank you for reaching out to us here with this concern. This does sound very puzzling especially since you have tried logging in on different equipment. No need to worry, our team specializes in all things Xfinity so I am sure we can get this repaired for you. I tested the site on my end and everything appears to be working properly so I don't think there's an issue with the website. Can you tell me if you get the error when you try and navigate to the Xfinity home page or does this occur only when you're signing into your online account? 

Visitor

 • 

2 Messages

@XfinityAmir Hi, thanks for responding. The error occurs whenever I login on app and website. The website works like normal as well on my end but not the login page. It kicks me out everytime I login in.

XfinityAmir

Official Employee

 • 

6.5K Messages

Thanks for this information, I tested the website and my mobile app to see if I could duplicate the error and I am able to login which means this problem is at the account level. Again no need to worry I have seen this before and we will get this fixed in no time. To better assist you could you please send me a private message (peer to peer) with your full name and street address? 

 

To send a "Peer to peer" ("Private") message:
Click "Sign In" if necessary
• Click the "Peer to peer chat" icon
• Click the "New message" (pencil and paper) icon
• Type "Xfinity Support" in the "To:" line and select "Xfinity Support" from the drop-down list which appears. The "Xfinity Support" graphic replaces the "To:" line
• Type your message in the text area near the bottom of the window
• Press Enter to send it

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

New to the Community?

Start Here