CaptCam's profile

New Poster

 • 

4 Messages

Sat, May 2, 2020 11:00 AM

Enable the browser with the XFI app on Samsung Galaxy 8+ Chrome

Enable the browser The web browser is disabled on this device. To continue, enable in Settings.

I am a new xFi user and am also getting this message.  When I attempt to sign into my account, I get an error message to enable my browser in Settings.  After clicking on the link, all I see is a list of every app installed on my phone.

Does it seem to be a lot of people with the same error??? What is the bug FIX??? 

THERE HAS NOT BEEN ANY ANSWER TO THIS ISSUE AND PROBLEM WITH THE DEFECT WITH THE XFI APP

XFI APP NEEDS TO CORRECT THIS BUG FIX IT!!!

Which settings need to be adjusted?

Responses

New Poster

 • 

1 Message

4 m ago

I had the exact same problem.  I got someone with an iPhone to help me.  It was super quick after that. 

It is deeply frustrating that xfinity forces us to use the app just to get the router started.  I tried following their alternative instructions, and the first step of the video I watched was "download the app." 
I was able to log into my xfinity account using the web browser on my phone.  I don't see why there wasn't a simple way to activate my new router using that account, but there wasn't. 
In some ways Comcast's customer service has gotten better, but not in this way. 

EG

Expert

 • 

87.2K Messages

4 m ago

10 month old dead thread now being closed.

New to the Community?

Start Here