S

Visitor

 • 

4 Messages

Wednesday, January 3rd, 2024 12:31 AM

Can't log in to app

This has been going on for 3+ weeks.

When I try to log in to the Xfinity app, I input my user name and hit the "Let's go" button.  Then I am returned to the same screen that says "Sign in with your Xfinity ID".   So I can't log in to the app.  I can log in to the xfinity.com website so I know my username and password are valid.

I have cleared my cache and browsing history.

I'm on an iPhone

Accepted Solution

Visitor

 • 

4 Messages

7 months ago

Ok folks I figured it out on my own, after 30 minutes in a chat with an agent that had me go down rabbit holes that didn't solve anything.   The Xfinity app uses Safari for user authentication, and the app relies on cookies to work correctly.  If you have cookies disabled for Safari, the app won't work.  You have to do this on your iPhone:

go to SETTINGS

Scroll to SAFARI

Scroll down to ADVANCED (it's way at the bottom)

DESELECT "Block all Cookies"

Then you can go back to the Xfinity app and hopefully login.

Good luck  

Visitor

 • 

4 Messages

7 months ago

PS I have also uninstalled and reinstalled the app.

4 Messages

25 days ago

I am having this issue, but i am a new customer, and i cant access the app. ive cleared the cache and cookies for safari and everything. Is there anything else i can do? spent about 4 hours on the phone with multiple people

Frequent Visitor

 • 

19 Messages

8 days ago

I had the same issue and the workaround above did not work for me (Block all cookies was already deselected). What fixed it was the following

- Force quit the Xfinity app

- Settings

- Safari

- Advanced

- Website Data

- Search for XFinity

- Delete all Xfinity website data

- relaunch the Xfinity app

forum icon

New to the Community?

Start Here