krbuts34's profile

Regular Visitor

 • 

3 Messages

Tue, Nov 23, 2021 2:16 AM

Advanced Security

I recently signed up for xfi complete. In the xfi app I get "try again later error"  when trying to turn on advanced security. On the xfi webpage I only have protective browsing option, no advanced security. Any help would be appreciated. No one seems to be able to fix this.

EG

Expert

 • 

91.7K Messages

2 m ago

Concern moved here to the Xfinity App help section for assistance.

Official Employee

 • 

196 Messages

2 m ago

Hello @kbuts34, thank you so much for your post on our Xfinity community forum for helping with your Xfi app and enabling and disabling your advanced security option. First I would like to make sure you are using the Xfinity app and not the Xfi app. The Xfi app would be an old version of the application and may not have all of the options you need to manage and control your Xfi complete options. You can take a look here at this page to see how to download the Xfinity app! https://comca.st/30Rw4zL

 

Make sure you are using an Xfinity ID that is either the primary user or account manager to ensure you have the right level of access to make these changes.

 

Regular Visitor

 • 

3 Messages

@XfinityAmandaB Thank you for your response. Yes I am using the correct Xfinity app. I verified this by selecting the link you provided. I am the Account manager. I do not have any of the advanced options enable, such as port forwarding or DMZ. I know this could cause issues if they were enabled. The app gives me the option to turn it on, but it always results in "Try again or check back later". The xfi website does not even give me the option. It just gives me the protected browsing option and suggests That I should upgrade to Advanced Security.

Official Employee

 • 

196 Messages

Thank you for checking @kbuts34 the settings are all still there in the app to manage but not all in the advanced security option. Have you by any chance checked the advanced options in all the tabs like your connect tab? I know port forwarding is located there and not with the advanced security options. You can check out how to set that up if you use these steps.

  1. Select the Connect tab.
  2. Select See Network (in blue) under your WiFi name.
  3. Select Advanced Settings under More Options.
  4. Select Port Forwarding from the menu.
  5. Select Add Port Forward.

If you can not disable or enable the XFi advanced security and the Port forwarding options are not available. I would say there may be an issue with the Xfi enabled gateway needed to take advantage of the Xfinity app to manage your settings. This would cause issues with the advanced security and managing any settings. I can check out your modem for you not a problem at all.

If you could send our team a private message with your full name, the name listed on the account (if different), and the service address associated with your account, I'd be more than happy to look into this for you.

To send a Private Message, please click on the chat icon in the top-right corner of the screen, next to the bell icon, and then type or select "Xfinity Support" to initiate a live chat.

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

New to the Community?

Start Here