BobQ's profile

Contributor

 • 

36 Messages

Sunday, February 12th, 2023 7:54 PM

Closed

"Advanced security on the go wasn't set up correctly" error message on iPad

I recently upgraded to xFi complete and have been playing around with some of the features that it offers. I was able to easily activate Advanced Security on the go on my iPhone but when I try to activate it on my iPad I get the message "Advanced security on the go wasn't set up correctly" and a "Got It" prompt but nothing that helps me go further to troubleshoot. I have restarted the iPad a couple of times and deleted any other VPN apps that were installed. My phone and iPad are both running the latest version of iOS and are configured similarly. (I did not have to do anything with the iPhone to get it to work.) I am reaching out to see if anyone has had a similar problem or if anyone might be able to help me troubleshoot this. Thanks!

Visitor

 • 

1 Message

1 year ago

I am having the same issue.

New Problem Solver

 • 

617 Messages

Hi @user_bf19d4

Thank you for taking the time to reach out and let us know you are experiencing issues with the Advanced Security. 

Can you please confirm if you are having the issues with an iPad as well? When attempting to make the changes are you on your home WiFi? 

I no longer work for Comcast.

Visitor

 • 

1 Message

Same issue and  YES connected to home Wi-Fi and still will not connect

(edited)

Visitor

 • 

3 Messages

11 months ago

I'm having the exact same issue.

Visitor

 • 

1 Message

11 months ago

I am havng the same user as well on iPad Pro. Phone is fine

Valued Contributor

 • 

406 Messages

Hello, @user_3fe197! Thank you for reaching out on the forums. I know your post is from a couple of days ago, but are you still having issues withhe security on the go feature?

I no longer work for Comcast.

Visitor

 • 

3 Messages

11 months ago

I am still having this issue: ​ when I try to activate Advanced Security on my iPad I get the message "Advanced security on the go wasn't set up correctly" and a "Got It" prompt but nothing that helps me go further to troubleshoot. I have restarted the iPad a couple of times and tried on my home wifi.  My phone and iPad are both running the latest version of iOS and are configured similarly. (I did not have to do anything with the iPhone to get it to work.) 

Official Employee

 • 

1.4K Messages

Hello @user_6c2967! Please confirm you are using a compatible Android/Apple mobile device:
Android 10 or higher. iOS 14 or higher (iPhones only – iPad and other Apple devices are not supported at this time.)

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

1 Message

@user_6c2967​ I am an Xfinity employee. Advanced Security on the go is not supported on iPads at this time. It will work on iPhones with iOS 14 or higher.

Frequent Visitor

 • 

17 Messages

11 months ago

I am having the same issue. I have tried same fixes as other users. My IOS is up to date. 

Problem Solver

 • 

571 Messages

Hi, there. Can you please make sure the Xfinity VPN profile is installed on your iPad?

ON IOS

  1. Open the Settings app on your phone.
  2. Scroll down and tap General.
  3. Scroll down and tap VPN.
  4. Verify the “Xfinity VPN” profile is installed.

Note: Advanced Security on the go was designed to turn on automatically when network settings are detected. The VPN toggle will remain as “Connected” and the Xfinity VPN will only establish a secure network tunnel when the device is connected to an unsecured WiFi network.

I no longer work for Comcast.

Visitor

 • 

3 Messages

When I click on VPN there is nothing there and it says "not connected."  If I click on it, it says "Add VPN Configuration."  

Official Employee

 • 

1.3K Messages

Thank you for confirming, @user_6c2967 . Can you please confirm what version of iOS you are running on your device?

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

6 Messages

10 months ago

I am having the same issue with my iPhone SE that is running IOS 16.3.1. 

Official Employee

 • 

1.3K Messages

Hi, @user_810c45. Thank you for reaching out. I hope you are doing well besides this current hiccup. I can see this has been frustrating, but I'll do everything I can to help. The Advance Security on the go feature is awesome to have for peace of mind, and it is available to all xFi Complete customers. I understand you are using a compatible device with the updated software (IOS 16.3.1) that should work as listed in the post you linked above. 

 

Have you made sure that Advanced Security is enabled on your home network as well? To confirm, when you get to step 4 (Xfinity App > Security > Advanced Security,) does it give you the option to select "I Agree" or does it not let you access this portion? If it does and you can select "I Agree," does it prompt you to do anything next or does it simply stop there? 

 

 

 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

6 Messages

Yes, advanced security is enabled for me, I just cannot enable “advanced security on the go”. I keep getting the following message:

Official Employee

 • 

1.3K Messages

Thank you for following up @user_810c45. If you have xFi Complete, the updated IOS, and Advance Security enabled on the home network, you should be good to go. Just to be safe, did you make sure you have the latest version of the app? 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

6 Messages

Yes, the latest version is installed.

forum icon

New to the Community?

Start Here