RLAlanis's profile

New Poster

 • 

1 Message

Fri, Jan 17, 2020 7:00 PM

5 XFi pods failed at same time, no accountability from xfinity.

anyone else ever had all of their XFi pods just fail at the exact same time?

after a power outage on tuesday all of my pods at home disconected (makes sense) but unlike previous times during a storm for example they didnt reccect.

No biggie..i tried manually through XFi app...no dice.

They all after powering on, stay rapidly blinking.

Called the following morning, wasted about a dozen minutes with 1 rep. no fix.
Called that evening, wasted upwards of 65 minutes with 3 different reps & did the tried & true unplug the modem & etc....no dice. That rep told me i would be getting replacement pods...
Got a call this morning from some international #, apologizing that i am not eligible since im past the 12 months (im 3 months over on 3, & 5 months over on the other 2 pods)
Today i spoke with 5 other reps & supervisers..some empathetic..1 even has experienced similar issues...he reccomended i swap out my modem/router....so i did....no dice.

ive spent over 7 hours in a 24 hour window on this nonsense.
i wish they would hold themselves accountable when its a technical issue with equipment they encourage you to purchase just to leave you high and dry when it fails prematurely (5 times over in my case) & hide behind the 12 month policy..

In my buisness, when i sell something & it suffers a total failure this early...i want it back to diagnose it & learn from it so others dont hace to deal with this...maybe xfinity would rather make more money off their cu$tomers instead of taking care of them.

*oh, & @Xfinity im still waiting for the supervisor from Minneapolis to call me 8 hours later...(even though i was told it would be within a "2 hour window".

useful info for others, no power surge occured, nothing else besides the XFI pods are affected..1 of the reps believes the XFi pods may have been receving 1 of their regular updates that are sent to them when it occured...but no way for them to reset it via theyre diagnostics ran.

Responses

No Responses!

New to the Community?

Start Here