Anonalogo's profile

Regular Visitor

 • 

4 Messages

Fri, Sep 6, 2019 4:00 PM

PSA for account login problems

For many days I was unable to login to my Comcast/Xfinity account, support forum, etc. My internet service was operating okay and every non-Comcast site behaved correctly, but all login effort on Comcast resulted in server not responding.

 

I couldn’t even send a private message to Comcast_Support because the forum requires login.

 

Incredible as this may sound, my problem was resolved by calling the main Comcast support number (888) 262-6300, answering the automated questions, and allowing Comcast to remotely reboot my modem. As soon as the reboot was complete I was able to login to Comcast in all of the normal ways.

 

This may not apply to your particular login problems. I’m simply posting this as a possible solution for relevant customers to try. Good luck!

This conversation is no longer open for comments or replies and is no longer visible to community members.

Responses

Comcast_Support

Official Employee

 • 

1K Messages

2 y ago

Hi @Anonalogo

 

Thank you for sharing your experience here on the Forums! We really appreciate it. In the future, if you have problem feel free to reach out to us here as we can also complete the necessary troubleshooting. Thanks for being a valued customer. Take care! 

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New to the Community?

Start Here