U

Visitor

 • 

1 Message

Mon, May 9, 2022 2:16 PM

"Looks like something went wrong" error and request to send equipment to apartment office instead of apartment number

Hello. I've been trying to create an Xfinity Internet and TV package multiple times across multiple browsers on both my phone and my desktop PC, but every time I get ready to check out and ship my equipment, I keep getting a "Looks like something went wrong" error. I've tried to set this up countless times, and it always fails on this last part. I also have another request. I'll be moving to an apartment this upcoming Friday, but Xfinity says that the equipment will take 3 to 5 business days to arrive. If it arrives early at my apartment number, I won't be able to pick it up. I'd like to have it sent to my apartment office for me to come to pick it up after I check into my apartment. Would this be possible?

Official Employee

 • 

674 Messages

5 m ago

Hi there @user_0292d9, thank you so much for reaching out to us here via our Forums page. I hope your morning is going by smoothly! I will be more than happy to help you make any changes you need to your current package and also help you transfer your services to your new location! Can you please send us a DM to start?

 

Here's the detailed steps to direct message us: 
 • Click "Sign In" if necessary
 • Click the "Peer to peer chat" icon (upper right corner of this page)
 • Click the "New message" (pencil and paper) icon
 • Type "Xfinity Support" in the to line and select "Xfinity Support" from the drop-down list
 • Type your message in the text area near the bottom of the window
 • Press Enter to send your message

forum icon

New to the Community?

Start Here