U

Visitor

 • 

1 Message

Fri, Jun 18, 2021 8:16 AM

I can't open internet.xfinity.com

Either I click on Xfinity Xfi sign (the one that looks like wifi sign) on xfinity.com (which I can log in) or directly go to internet.xfinity.com, the site just won't open. It's stuck on 'loading' status, then it says 'Something went wrong'. Same thing for Xfinity mobile app.

Another strange thing is everything still works, including all the mobile phones and my IPad, but Firestick wouldn't work. Well, it works but if you want to stream anything, it only plays maybe a second then makes you wait for couple of second then plays for less than a second. But the video quality is high unlike, when you have a slow internet, the streaming quality would go down. 

I can still access 10.0.0.1 but I do not know what to look for on the admin site. 

Can someone tell me what is going on?

Responses

Official Employee

 • 

309 Messages

1 m ago

@user_7ac550

Hi there! I'd be glad to ensure that this gets looked into further. I'm terribly sorry that you're having issues with your Xfi service. Being unable to sign in, makes it difficult to manage your internet service. I've also had a few run ins with the fire stick as well and feel we can assist you with this also. Please send a private message with your name, the complete service address (including city, state, ZIP, suite number, etc), and the phone or account number, and any pertinent details-- like the ticket number(s)-- so we can help. You can do this by clicking on the icon in the upper right corner of your screen and send a message to the shared handle "Xfinity Support"

New to the Community?

Start Here