K

Visitor

 • 

4 Messages

Fri, Jun 3, 2022 11:44 PM

Hmm, the page didn't load correctly

I can not access my account page through the Xfinity customer portal. It always says "Hmm, the page didn't load correctly". Found another forum post where a user was having the same problem and none of the proposed solutions work for me: https://forums.xfinity.com/conversations/signin-and-account-management/hmm-the-page-didnt-load-correctly/612edd4eef55351432c4057a

Supremely frustrating that I can't see any of my plan info or edit my account in any way, and even worse that the only mode of support is through a forum

Official Employee

 • 

284 Messages

4 m ago

Hello @kyle812 I am so sorry to hear that you are having issues with our online service portal. Can you tell me what you have tried so far to troubleshoot the issue? Like clearing out the cache and cookies? I don't want to have you to repeat anything if possible. 

Visitor

 • 

4 Messages

4 m ago

I have tried clearing my cache, tried in incognito mode in multiple browsers, tried to create an Xfinity username like it said to do in the linked post, but when I put in my phone number and then enter the verification code I'm sent it tells me "This information doesn't match our records".

Official Employee

 • 

108 Messages

Hey @kyle812 I see you mentioned that the system said "this information doesn't match our records", please make sure the username is reflecting correctly for our system. You can use the URL shown here https://comca.st/3Q2MqKx to make sure the username is reflecting correctly.

 

If you need to reset password

 

  1. Go to https://comca.st/3NV2EDt.
  2. Enter your Xfinity ID you retrieved above and click Continue. ...
  3. Complete the security check by typing the moving letters in the box. ...
  4. Select the way you want to recover your password and click Continue. ...
  5. Create and confirm your new password.
I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

4 Messages

@XfinityFelicia​ I go to that url and enter my phone number, then enter the code I am sent and it still says "this information doesn't match our record". I try again, this time entering my email, then entering the verification code I am sent and I still see the same error message. I know for a fact that I have an account with both that email and phone because I can log in to the xfinity page and see my name in the top right corner, but when I try to navigate to my profile page I get the original "Hmm, the page didn't load correctly".

(edited)

XfinityBrie

Administrator

 • 

644 Messages

@kyle812

 

What device are you accessing from--phone, tablet, desktop, laptop? Do you know the model number of the device in question, and is it universally giving the same error message across the board?

 

The last I looked into this particular issue most folks with the error prompting were using a device that couldn't load up the pages due to the device age. If that isn't the case here, we'd submit the account to a repair team to look into things.

 

We have to create an official report of any and all affected accounts with the specified issue so the folks who do these sorts of repairs can isolate if it's a specific account or device issue.

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

4 Messages

I'm using a desktop PC that I built, all components are less than 3 years old so I don't think it would be due to device age. I tried on my phone (Samsung Galaxy S22+) as well as my work laptop (Macbook Pro) and got the same behavior every time.

XfinityBrie

Administrator

 • 

644 Messages

@kyle812

 

Oh, nice--I love custom builds. My current PC is in pretty desperate need of a makeover and upgrade. Keep putting it off because bills come first lol

 

Alrighty let's go ahead and open a repair claim for the account, sounds like something is not clicking over on the backend. Could you throw us a direct message?

 

To send a direct message:

 

Please only send a direct message when requested by an official employee--sending a chat when not requested may result in the chat being lost given the high volume of chat requests received daily.

 

  • Ensure you are first signed in, then you will see an icon at the top right of your page. Click that or follow this link: https://comca.st/3MizjSt
  • From there, click the 'New Message' icon. In the 'To' field, type 'Xfinity Support'.
  • Type your message in the text area that appears at the bottom of the window and hit enter to send. An official employee, such as myself or whoever is first available, will respond.

 

We ask that you please include your name, the account holder name (if different), and the service address alongside your inquiry so we can best assist. 

 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick
forum icon

New to the Community?

Start Here