U

Visitor

 • 

2 Messages

Tue, Oct 12, 2021 6:27 PM

Hmm, the page didn't load correctly

I try to log in app and browser, but I cannot access my account.

The display showed "Hmm, the page didn't load correctly", "A Communication error has occurred..."

What should I do?

Responses

Official Employee

 • 

2.8K Messages

5 d ago

Hi there, user_f334a5. Thanks for taking the time to create a post! We can help. 

 

Are you a new customer or did you recently sign back up for service?

Visitor

 • 

2 Messages

@XfinityMorgan 

I'm a new customer.

I signed up for the internet service of Xfinity a few days ago.

Official Employee

 • 

3K Messages

Well in that case: WELCOME! :D

We are happy to have you here. I'd love to check into the status of your new account for you so we can get you started off on the right foot. Please send us a Direct Message with your first and last name as well as your service address so we can assist.

To send a Direct Message, please click on the chat icon on the top right of this page, next to the bell. Make sure to send the message to our singular handle "Xfinity Support" and we will get back to you ASAP.

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

1 Message

Hi, I didn't see the chat icon on the top right next to the bell. How can I reach out for support, I have the same issue 

New to the Community?

Start Here