lindak579's profile

New Poster

 • 

4 Messages

Tue, Nov 24, 2020 7:00 AM

changed modems and landline wont work

Recently upgraded my modem and from unplugging the phone line in the old one to plugging it in to the new one there is now no service.  Why?  Have called and wasted tons of time on the phone to no aviail and now I have a ticket number and no one has called back.  

 

Frustrating.  

Responses

Accepted Solution

New Poster

 • 

1 Message

8 m ago

I had the same issue and after a week, another run to their store to replace the modem (again), and several calls to customer service, have finally gotten the problem solved and now have a working landline.

 

As explained to me (I used to work in computer repair and had a conversation about the problem with the representative after resolving the issue):

 

Apparently the cause in my case was that the new modem of this model does not know that the phone is already supposed to be activated as this information was stored on the old modem. The new modem regarding this is still blank and a phone activation signal has to be performed by the phone activation reps. The agent I talked to said they were aware of this problem and were working on it, but for now it might be helpful to ask about this as a starting point if you need to call customer service after experencing this issue.

New Poster

 • 

1 Message

8 m ago

same problem happened to me yesterday 😞

New Poster

 • 

4 Messages

8 m ago

let me know if yours gets fixed

 

Regular Visitor

 • 

3 Messages

8 m ago

Same exact problem here.

 

New Poster

 • 

1 Message

8 m ago

Same, if a solution arises I would love to know
gerald4506

Contributor

 • 

22 Messages

8 m ago

Same exact problem. Phone has not worked in a week since tech installed new modem.
I recall someone mentioning there was some number you have to call to “port” your number sometimes when you get a new modem. Details are fuzzy.

New Poster

 • 

4 Messages

8 m ago

I agree.  I appreciate the information and now I have to gear myself up to call and talk to someone who willnot know what I am talking about.   Calling them makes me physically ill. 

New Poster

 • 

2 Messages

8 m ago

I am having the same problem since the Comcast installation 3 months ago. 
The last post is very informative, thanks! At least now we know what's the root cause and that only a Comcast rep can reactivate the phone.  
Why don't they at least let people know upfront about this issue and what they need to do?! What a frustration and waste of time for all of us!!!

 

gerald4506

Contributor

 • 

22 Messages

8 m ago

A tech came today and admitted that he accidentally hooked up my phone connection incorrectly. I now have a dial tone.

He did say that people are having some issues with phone service with the new modem/routers.
ancient46

Contributor

 • 

129 Messages

8 m ago

This is the reason I have a separate modems for phone service and internet. When we moved into our house in 1997 I had a modem installed for both but soon bought my own internet modem for the internet service. I have since changed the internet modem seeral times for Comcast end of life reasons.

however I never needed to replace the modem for phone use although Comcast internet regularly want it replaced because it no longer works for the internet. However Comcast has not changed the way  the home phone connects and that modem still worked for it. It finally was replaced due to a Comcast Store contract renewal failure in 2016. 

New to the Community?

Start Here