DCom1000's profile

Regular Visitor

 • 

2 Messages

Mon, Oct 10, 2022 1:45 PM

Caller Id not working

I recently upgraded my xfi gateway to the XB8. I have xfinity internet, TV, and voice. Since I upgraded my gateway, the caller ID feature has not been working. All calls come in as anonymous. I contacted live chat who restarted the modem and tried to fix it, but it never got fixed. I was told advance support would contact me in an hour, but no one ever called. Ive been reading on these forums how advance support has to activate some switches on their end to get this working. I really need the caller id to work properly. How can I make sure a ticket has been open for advance support and most importantly, how can this issue be fixed?

XfinityKei

Official Employee

 • 

163 Messages

1 month ago

I have a home phone as well and understand how important the Caller ID is. 

@DCom1000 Thanks for bringing your concerns to our community for assistance. 

I am happy to troubleshoot with you and check on the status of your call backs. 

Have you had the opportunity to reset your phone bases and remove the batteries if you have a cordless phone. 

Please send our team a direct message with your full name and full address so that we can assist you further. 

To send a "Peer to peer" ("Private") message:
Click "Sign In" if necessary
• Click the "Peer to peer chat" icon
• Click the "New message" (pencil and paper) icon
• Type "Xfinity Support" in the "To:" line and select "Xfinity Support" from the drop-down list which appears. The "Xfinity Support" graphic replaces the "To:" line
• Type your message in the text area near the bottom of the window
• Press Enter to send it

forum icon

New to the Community?

Start Here