U

Visitor

 • 

1 Message

Sat, Aug 28, 2021 2:48 PM

xfinity flex and denon AVR-589 (AV SURROUND RECEIVER)

The connection is HDMI from the FLEX to the AVR-589 is HDMI and then from the AVR-589 to the Samsung TV is also HDMI going through the appropriate ports on the AVR-589.  The video and audio pass through fine, but the surround sound speakers are not working.  How do I get the surround sound speakers to work?  BTW - with my xfinity cable box everything worked fine and the only thing changed was I went from the TV Box to the Flex box.

XfinityJoeB

Official Employee

 • 

6.9K Messages

3 m ago

Hello user_df8bf1. We appreciate you visiting and posting on our Forums. Have you tried to bypass the AV Receiver, to see if surround sound works? Doing this test will reveal if there is a settings issue within your Flex box. Note that not all programs feature full surround sound. In some cases, programs may only contain left and right stereo audio.

Visitor

 • 

1 Message

@XfinityJoeB How do you send sound to 7 speakers without he use of the Denon, if bypassed?

Official Employee

 • 

30 Messages

In this case, we would be bypassing all the speakers and using just the internal speakers of the TV to see if you still have the audio issue. We need to eliminate the possibility of it being the device that routes the sound.

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

New to the Community?

Start Here