bird3d's profile

New Poster

 • 

7 Messages

Sat, Aug 15, 2020 11:00 AM

Unable to select language on flex box with XR16 remote.

Just got the flex box and can scroll through the language and can't select one. Have followed the steps to factory reset the remote using the * and the i button for 3 seconds and then pressing power, back button and volume down. Tried pressing the mic button to pair it up and still nothing.

Responses

Official Employee

 • 

113 Messages

9 m ago

Did you try connecting via Ethernet to the modem and then reboot the device? Does the language screen have a blue or black background?
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Solution.tick

New Poster

 • 

1 Message

7 m ago

Just happend to me, new customer...   The issue was with the new XR16 remote...  I guess they are still working the bug out of it.   The technican replace it with the older model to fix the problem.

 

So after searching message boards looking for a solution; the 30 minutes on the initial ssupport phone call; and the time spent with the  onsite technican going through the initial loading of the software into the TV Box...  all told took about an 90 minutes from my day; all for a "Free" product.

 

My question is... why can't Xfinity spend some time preloading the software and testing the hardware prior to shipping it to the customer? 

New Poster

 • 

1 Message

7 m ago

This is exactly what happened to me.  Multiple calls to comcast support, them shipping new remote unable to fix. Happened across this thread and plugging into ethernet and waiting for the box to update itself did the trick. Menu of 4 languages on blue background initially--could scroll but not select.  After plugging into ethernet, menu of 3 languages on black background appeared and things started working.  Glad to have found the solution, but completely ridiculous hoops to jump through.

Frequent Visitor

 • 

9 Messages

7 m ago

I'm in the same boat with language selection, but connecting over ethernet hasn't helped. I wonder if all of the people for whom ethernet worked also had old firmware on their Flex. Since mine is presumably up-to-date (has 3 instead of 4 languages listed), the firmware update doesn't happen, and the ethernet trick doesn't get the remote working.

New Poster

 • 

1 Message

6 m ago

Is there any fix to this without an Ethernet cable? I do not have one.

Frequent Visitor

 • 

9 Messages

6 m ago

In the other thread, ComcastChad was able to force a firmware update on my device. It might be that enough days connected would have resulted in an update without his help. I'm not sure that the Ethernet connection is a necessary part of getting the update.
ComcastChad

Official Employee

 • 

1.2K Messages

6 m ago

How many languages do you see? 3 or 4?   The device needs to be online in order to push new firmware remotely. 

 

Did you get this box shipped to you or did you pick up at a retail store?

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Solution.tick

Visitor

 • 

1 Message

2 m ago

I had the same problem with language setup as well and found solution post from Yojoe0707 very helpful. For now all the initial setup has to be done from direct connect, hopefully Xfinity fix that issue somehow.   I don't know how the heck the Flex box going to be able discover your router SSID and password automatically without going through direct connect.

Visitor

 • 

2 Messages

2 m ago

We just received our Infinity Flex and am having the same problem. Our router isn't really close enough to the TV to actually hook it up through an ethernet cable. We have our own modem. There are 4 languages coming up on the screen when I plug in the Flex. I can move up and down on the language screen but can't actually select. I have a remote that doesn't have numbers on it.

Official Employee

 • 

113 Messages

Can you try the following?

  1. Connect your Flex device to your modem/router via ethernet, don't worry about hooking it up to the TV.  Make sure the Flex device is powered on as well.  Let it boot up for about 10 minutes then try rebooting the device, unplug the power cable for 30 seconds then plug back in.  Let it boot up again for about 5 minutes.  
  2. Then take it back to the original location and connect it to your TV and see if you can select a language now.

This issue tends to happen on devices that have very old firmware and needs to be online in order to download an updated version.   

How did you receive this flex device?  Was it shipped or did you pick it up an Xfinity retail store? 

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Solution.tick

Visitor

 • 

2 Messages

That worked but [Edited: "Language"] if that remote isn't super touchy about where you aim it.

(edited)

Official Employee

 • 

113 Messages

Glad that worked, yes initially you need to be in close range until the remote is  paired with the flex device. 

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Solution.tick

New to the Community?

Start Here