bird3d's profile

New Poster

 • 

7 Messages

Sat, Aug 15, 2020 11:00 AM

Unable to select language on flex box with XR16 remote.

Just got the flex box and can scroll through the language and can't select one. Have followed the steps to factory reset the remote using the * and the i button for 3 seconds and then pressing power, back button and volume down. Tried pressing the mic button to pair it up and still nothing.

Responses

Official Employee

 • 

113 Messages

10 m ago

Thank you - that helps our support team- I will be sending this over for someone to take a look.

Can you try a couple more troubleshooting steps? Reboot modem and flex device again and pls make sure you are directly pointing the remote directly at the front of the device when selecting OK.
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Solution.tick

New Poster

 • 

1 Message

10 m ago

I am unable to select a language as well. I can scroll through them all but I can’t select one. I’ve tried everything I can to resolve this issue and still nothing.

Official Employee

 • 

113 Messages

10 m ago

Do you see three or four languages?
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Solution.tick

Frequent Visitor

 • 

5 Messages

10 m ago

Rebooted modem and Flex and unpaired again.

When I plug everything back in and it’s up and running it goes directly to the language select screen. Still can’t select a language but am able to scroll.

So I tried unpairing for the hundredth time. Seems to be successful as I see the green light then the flashing blues. My question is: what is the next step to pair the remote?

This is what support says:

“Make sure the remote batteries (AA) are installed and your TV and Xfinity Flex TV Box are powered on. Also, set the TV input to correspond with your Xfinity Flex TV Box.

Point the remote at your TV Box and press the Voice button once.
Follow the instructions on screen to pair your remote for voice control.
Once your remote is paired, follow the on-screen instructions to set up power, volume and input control for your TV.”

So, to pair, just hit the voice button once and follow the on screen instructions? It does nothing, there are no instructions other than the language select screen that I’ve been stuck on the entire time.

Very frustrating.

Official Employee

 • 

113 Messages

10 m ago

Those steps are for after activation, we pair the remote during the activation process. For some reason the OK key press isn’t working which triggers the remote to pair with the flex device.
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Solution.tick

Frequent Visitor

 • 

5 Messages

10 m ago

Gotcha. So pairing/activation happens when you select the language with the ‘Ok’ button?

What’s the next step if that doesn’t work?

And to clarify, the remote is obviously paired in some capacity, since the up and down buttons work (though the red indicator light flashes when I press them) and moves the cursor accordingly. The ‘Ok’ button also registers a red light when pressed but nothing happens. And I’ve tried selecting all four languages just to bypass.

Thanks for the help by the way, any ideas on my next step? Send back?

Official Employee

 • 

113 Messages

10 m ago

I’m going to have someone take a look tomorrow. You can also try swapping for a new remote and flex device at an xfinity retail store.
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Solution.tick

Official Employee

 • 

113 Messages

10 m ago

Can you try replacing the batteries as as last resort and see if that fixes it?
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Solution.tick
ComcastChad

Official Employee

 • 

1.2K Messages

10 m ago

Hi All - 

 

For those having issues with language selections, can you try connecting your device over ethernet and then reboot your device before attempting to select the language?  Once you have activated you can re-connect over Wifi.  Sorry for the inconvenience.  

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Solution.tick

Frequent Visitor

 • 

5 Messages

10 m ago

Ok, so while inconvenient (TV w/ Flex is downstairs and modem and router are upstairs) connecting to ethernet eventually worked!
Here was the process: Connected ethernet to Flex device and it booted up to the three language screen select this time. Had always been the four language screen up to this point using WiFi. Same result, however. Could scroll up and down but not select either of the three languages.

After a couple minutes a ‘Remote not working?’ menu popped up with guidance on how to pair/unpair and making sure the remote is pointed directly at the box (lol, thanks - tried that 20+ times). I did it twice more and nothing happened.

I was unable to select the ‘Ok’ button to acknowledge the ‘Remote not working?’ pop-up. So I started writing a response and after a couple minutes the device (Flex) looked like it randomly rebooted once, possibly twice and bingo! Remote works!

Just to note, I did try swapping out the batteries as mentioned above and that didn’t work. Looks like connecting to ethernet is the golden ticket. Luckily I had a moveable mesh point with ethernet port.

Thanks to all for the help!

New Poster

 • 

1 Message

9 m ago

Thanks for letting us know exactly what happened!  The same thing happened to me, so I connected with Ethernet.  I was getting no response, but in a few minutes the "remote not working?" came up just as you said.  So then I followed your narrative and everything happened exactly as it did for you. So far everything is working. Saved a lot of frustration by waiting a few minutes here and there for things to work themselves out.

New Poster

 • 

1 Message

9 m ago

Ethernet hook up also worked for me! After hooking up with the ethernet and connecting successfully, I  then unhooked the ethernet to set up wi-fi connection to Flex. Then moved the Flex back to the orignlal TV. 

New Poster

 • 

1 Message

9 m ago

Thank you for posting this! 😎

Your post was 'the solution' to my activation problems as well. The ethernet cable (and patienly waiting for the box to recognize the remote) is the answer to getting the xr16 remote to function (past the language selection). Even got the Flex to find my wifi. 

I am now up and running... into new problems w/ voice control... but that's another thread. LOL.

 

New Poster

 • 

1 Message

9 m ago

Amazing that so many people on here are having the same issue and there doesn’t seem to be a solid fix. I’ve tried every option listed in this thread and nothing works. Doesn’t seem to be worth the hassle. You would think that these hardware/software issues would be corrected prior to the launch of Peacock.

New Poster

 • 

1 Message

9 m ago

I am having the same issue - have done factory reset on remote a few times to no avail. Have tried pairing Flex device with router via WPS, still not working. I am able to change language selections, just can’t select one.

New to the Community?

Start Here