question_asker's profile

New Poster

 • 

1 Message

Fri, Sep 4, 2020 3:00 PM

Closed

RFE: Auto switch between DD+ and Stereo PCM based on content audio type

 


Watching video content with a stereo audio source, most users prefer to set the home theater receiver to a surround-extrapolation mode (on a Sony receiver, these modes are CSTEX-A, Dolby Pro Logic II, etc.; on Denon, they are called DTS Neural:X or Dolby Surround, etc.) in order to send voices to the center speaker and ephemeral sounds to the surrounds.

When the Flex box is set to put out Dolby Digital Plus, but is playing a video source that just has stereo audio, Flex hardcodes the stereo audio into front-left and front-right channels of the 5.1-channel bitstream, and sending out silent channels for the rest.

However, on most home theater receivers, audio can only be played strictly as received from a multi-channel bitstream. The receiver cannot take a 5.1-channel bitstream (that just happens to have silence on 3 of its channels) and upmix just its FL and FR channels to 5.1 channels -- it doesn't make sense.

If one sets the Flex's audio output to strict Stereo PCM, the receiver can upmix. However, to watch a DD+-encoded show in surround, one then has to go back into the audio menu and choose the second or third option. Much of the video content available is in Stereo PCM, and others are DD+-encoded. Switching back and forth manually is a real pain.

Please add a setting in the audio config menu to instruct Flex to put out Stereo PCM signal with stereo sources, and DD+ signal for surround sources. Other media players do this by default with configured for a DD+-capable receiver.

Thanks!

Regular Visitor

 • 

3 Messages

1 y ago

So, I've been struggling with this same issue.  I have the Flex hooked up to my receiver which displays/auto-detects audio setting - it's how I know I'm getting true DD...I have Flex audio set at auto...but even with movies or shows I know to be stereo-only (a number of Hulu titles, Peacock titles)...my receiver shows 5.1.  But it's not outputting as 5.1, it's outputting 2.0 (correctly).     This is just a glitch I've got to deal with, right? LOL   

Yes, clear as mud, I realize.

New to the Community?

Start Here