Simitar2100's profile

Frequent Visitor

 • 

7 Messages

Thu, Feb 11, 2021 2:00 PM

Closed

Problem setting up Flex

The Flex box hangs up on the "Welcome Connecting to your entertainment experience" screen. It has been stuck on this screen all day. I got info to come up on the bottom of the screen showing that it is connected toWiFi and showing it's MAC address. I am using an my own modem & router. Any suggestions to get it to finish setup.

New Poster

 • 

1 Message

1 y ago

I just had [Edited: "Inflammatory"] tell me that my TV isn't compatible and that when i buy a new TV i can call and get it activated.   

(edited)

XfinityChad2

Official Employee

 • 

228 Messages

1 y ago

are you seeing any type of error message on the TV? Can you provide some more details so we can help troubleshoot?
XfinityChad2

Official Employee

 • 

228 Messages

1 y ago

1) try unplugging the flex box for 30 seconds then try again.

2) If your modem has a WPS button, can you try pressing the wps button on the flex device and then on your modem. Or you could try connecting the flex device to the modem via Ethernet to get thru the activation steps.

Frequent Visitor

 • 

7 Messages

1 y ago

I unplugged the Flex box and left it overnight. I also turned the modem and router off. This morning I turned them on and plugged in the Flex box. Now it cycles between the first Welcome screen, the "Welcome Connecting to your entertainment experience" screen, and then a blank screen. My modem does not have a WPA button. I am using a Arris modem and a Linksys router.

Frequent Visitor

 • 

7 Messages

1 y ago

I don't get any error message on the screen. My internet is in another room. I would need a very long Ethernet cord (about 25 feet) to connect that way. I was on the phone with customer support for over an hour and they were no help at all. I got a second Flex box and it does the same thing as the first one. It cycles between the first Welcome screen, The Welcome connecting to your entertainment experience screen, and a black screen.

XfinityChad2

Official Employee

 • 

228 Messages

1 y ago

Can you share the model info of your modem and router?

Frequent Visitor

 • 

7 Messages

1 y ago

I am using a Arris Surfboard Modem Model # SB6183 and a Linksys N600 Dual Band Smart Wi-Fi Router Model # EA2750.

Frequent Visitor

 • 

7 Messages

1 y ago

BEWARE! Now I am being charged for Flex service. And it doesn't even work!!!!

Visitor

 • 

2 Messages

1 y ago

I have an Arris modem. Was told Flex box won’t work with it. This was my 3 rd call to xfinity. First call I was told he’d look into it and call me back. His name was Reese. Then I had a woman the second time I called and she said a tech would arrive today btw 10-12. No one showed. She lied. 🙄 3rd call the support person said flex won’t work with my modem. 

Visitor

 • 

2 Messages

1 y ago

Funny thing is it (Flex) was hooked up before when tech guy came a few months ago.... there was a modem issue then too... but, the guy hooked up my flex. 
So over it. I better not be being charged for it. They can have it back. 
only good thing about Xfinity support is I spoke to Americans that I could actually understand. 

XfinityChad2

Official Employee

 • 

228 Messages

1 y ago

Can you provide some more details on what issues your experiencing?  Is there a specific screen or error message your stuck on? 

forum icon

New to the Community?

Start Here