Geneamon's profile

New Poster

 • 

2 Messages

Sat, Jul 4, 2020 2:00 PM

New Flex won't turn on

I just switched to xfinity wifi and got a flex streaming device with it. My xfinity wifi is set up in another room. I have plugged the flex in to different outlets, and used different hdmi cords and ports on my tv. But still the flex wont turn on, my TV screen doesn't show any indication that the flex hooked up to the hdmi is on. The flex has a white light though. The HDMI ports and cords I have used work with other devices. I keep pointing the voice remote at the front side of the flex and pressing power but I get a red flash on the remote and no response from the flex. Can anyone tell me if theres something I can do to fix it, or if maybe the box was damaged in transit? I cannot move the router or the flex.

Responses

XfinityChad2

Official Employee

 • 

141 Messages

1 y ago

Try rebooting the flex box, the white light means it’s on and you should see a welcome screen and then a “select your language” screen to start the activation process. Also maybe try a new HDMI cord and different input.

New Poster

 • 

1 Message

1 y ago

I am having the same issue. Received my new flex but remote light will only flash red and tv doesn't recognize the box is connected, despite restarting multiple times. 

XfinityChad2

Official Employee

 • 

141 Messages

1 y ago

Are you sure you're on the correct HDMI input?  So to clarify your issue,  your getting a no signal message on your TV b/c the flexbox is not being recognized by your TV?

New Poster

 • 

6 Messages

1 y ago

I too have this issue.  Though mines a little different.  I connected everything with the cables it came with, all new.  Connected it to a HDMI 2.0 for the 4k resolution.  I know the port works because my Playstation 4 Pro was connected to it.  

When I powered it on the first time I saw the "Welcome" screen for like 2 seconds and then I get "signal lost" from my TV screen.  Then a few seconds later the "Welcome" screen comes back, then "signal lost again" and back and forth, over and over.  

I don't understand what it's doing and I'm one of those techy kind of people everyone else asks for help from.  I figure the box is just bad, maybe comcast had these Flex boxes made cheap and they are all garbage.  Does anyone know if the Xfinity Stores are open and accepting returns on these wonderfully reliable devices?  I'd like to get a replacement and see if that works, but I'm already discouraged and don't expect any luck.  And really the only reason I wanted this thing is for Peacock so I could watch the "Psych 2" movie on USA when it comes out.

Visitor

 • 

1 Message

@rosiere79 I am having that same exact issue I was told by one of the techs that I needed to get a new modem for it to work with the flex. I returned my old modem for a new one & I'm getting the same thing. I plug it into HMDI port 1 & it keeps connecting then disconnecting continuously. I know it's not my TV bc I used that port for my roku & it worked perfectly fine. I'm thinking maybe it's the flex box but I honestly don't even want to go back to the store to get a new one just for it to happen once I pull in the "new" one. And I'm sure as f**** not going to pay to have a technician to come out when all you should have to do is plug it in & instantly work but I can't even see anything on my TV that it's even working. So frustrating! 

XfinityChad2

Official Employee

 • 

141 Messages

Do you see a small white light on the flex box?  Do you see anything on the TV?  Welcome message? no signal?  

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

New Poster

 • 

2 Messages

1 y ago

My flex wont turn on. It’s plugged in and no white light appears
XfinityChad

Official Employee

 • 

1.2K Messages

1 y ago

Are you able to exchange at an Xfinity retail store?

New Poster

 • 

2 Messages

1 y ago

I am having this same issue. Is everyone’s flex device busted?

Visitor

 • 

1 Message

@Leard006y yes same issue 

Official Employee

 • 

145 Messages

@user_e7b301, are you seeing the light on the flex turned on or any message on the TV?

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Contributor

 • 

42 Messages

1 y ago

My Flex has been working for several months. I'm connected to my TV through an HDMI switch. When I first power up the TV at night, it shows a message that it's trying to load configuration from the HDMI port and that goes on for a while and finally gives up. My solution is to briefly switch the HDMI switch to another channel and then back to the Flex. This seems to wake up the HDMI port on the Flex. I'm betting the Flex keeps its HDMI port in a power-saving mode and fails to negotiate a proper power startup with the TV or switch. I have a similar problem with my old video card in my PC and my LG TV I use for its display. I have to power up the TV first and then hit a key on my PC to get it to connect. Any other order and it fails. So the HDMI standard is having the same problems we saw with USB when it first came out. 

New Poster

 • 

1 Message

8 m ago

I’ve tried unplugging and plugging back in, disconnecting from wall and back in and pressed the wps button on the bottom but the light on the flex won’t come on.

Visitor

 • 

2 Messages

4 m ago

I am having a similar problem. Box started fine, got registered, works. Then I switch to my other HDMI and after awhile, I switch to Flex hdmi2 and no signal. I notice when selecting the source, there is a red power icon on the hdmi2 icon. If I switch the hdmi2 to my dvd and turn it on, the port wakes up. Then back to Flex box and it’s working. I tried turning power save options off on the flex but that didn’t work.

Visitor

 • 

2 Messages

@user_9f858

I discovered my problem. I am going through a sound bar and it was switching inputs. When I switch the sound bar back to hdmi, it works. 

Visitor

 • 

4 Messages

4 m ago

Having the same issue i even went to grab a new box and it’s the same thing. All of my other streaming boxes and Ps5 all connect perfectly fine. 

Visitor

 • 

1 Message

3 m ago

I just got my brand new Flex box and tried plugging into different outlets. The HDMI is on the right port but the box won’t turn on. What’s wrong with these boxes?  This is frustrating! 

Visitor

 • 

1 Message

2 m ago

Just got one of these boxes and set it up, getting a white light and everything's plugged in correctly hut my hdmi input channel is showing no signal. Thought I had to activate it ,but didn't see anything for that and now seeing that this issue seems pretty common and not confident it will work. I have a Roku TV that I'm plugging it into, I wonder if it has to do with the brand of TV and possibly certain brands not recognizing it?

Official Employee

 • 

155 Messages

Hi @user_394d7a

Thank you for reaching out through Forums! You've come to the right place and I am happy to help you troubleshoot your Flex box. My mission is to help get things working as they should be! A white light is normally a good indicator the box is on.  Please send me a peer to peer message with your first/last name, and the full service address in question so that I can review our options. 

• Click "Sign In" if necessary
 • Click the "Peer to peer chat" icon (upper right corner of this page)
 • Click the "New message" (pencil and paper) icon
 • Type "Xfinity Support" in the to line and select "Xfinity Support" from the drop-down list
 • Type your message in the text area near the bottom of the window
 • Press Enter to send your message

 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick
XfinityChad2

Official Employee

 • 

141 Messages

2 m ago

What happens when you reboot the box - do you see a welcome message on the TV.   The white light means it’s on, need to figure out why your TV/HDMI is not recognizing the flex device is connected.   Are there any other TVs in the house you can test on?  

if you look on the bottom of the flex device what’s the model?  A-Xi6 or T-Xi6 

New to the Community?

Start Here