ktan's profile

New Poster

 • 

2 Messages

Mon, Aug 10, 2020 1:00 PM

Closed

Can't activate new Flex box

I just recieved a Flex box and I'm trying to activate it - I can get it all plugged in and powered up, it says it's going to take a minute to set up, and then shows me a screen about connecting via WPS or Manual Setup.  I'm unable to move foward from this screen.  I can tell the remote is working because it lets me toggle between those two options with the arrow buttons, but no other buttons do anything and it won't let me select either option.

 

I have my own router and modem (not Xfinity branded) and I've tried unplugging everything, removing the batteries, and letting it all sit for a while to reset.  No luck.

Accepted Solution

XfinityChad

Official Employee

 • 

1.2K Messages

2 y ago

Did you try pressing the WPS button on the Flex device and then following the on-screen instructions?

 

New Poster

 • 

2 Messages

2 y ago

Thanks Chad, this did help to get me connected to the network but I was still having troubles with the remote.  I did have a technician out to help and they were able to replace the remote and get it set up.

XfinityChad

Official Employee

 • 

1.2K Messages

2 y ago

Thanks for the reply, good to see you up and running and enjoying your Flex device. 

Visitor

 • 

3 Messages

I was told today by an Xfinity (online help, level one support) guy that I need the Xfinity modem for the Flex 4k to work. Is this true, as I just returned my device. That's after spending two days on the phone with them and talking to multiple techs. Jeez, these people have NO idea what they are doing or what's going on with their own products

 Does anyone uses this with your own modem&router? I had mine connected via Ethernet also. Thanks.

Visitor

 • 

1 Message

I own my own cable modem & Flex box works just fine. Had some difficulty with remote voice activation but works now. Good luck.

forum icon

New to the Community?

Start Here