S

Visitor

 • 

8 Messages

Mon, Jul 19, 2021 10:23 PM

Xfinity Connect Web Email Portal Not Loading

Like a lot of other people, whenever I try to access my email via the web portal, I just get sent to the My Xfinity homepage.  It shows the transition screen saying "loading your email" but the email web app never comes up.  I've tired accessing it on a pc, mac and my phone using three browsers on each of them - all with cleared browsing histories, caches and cookies.  The last time I logged into the portal was a few months ago.  I recently set up a second location on my account and changed my primary contact account to my gmail account, but other than that, no changes that I can think of.

Responses

Visitor

 • 

8 Messages

2 m ago

I've also tried to set-up my Comcast email account on my iphone mail client.  It won't let me create an account and gives me an error saying that Comcast's "...IMAP server doesn't support Password authentication."  :-(

So, I basically have no way to access my comcast email account, from what I can tell??

(edited)

Visitor

 • 

8 Messages

2 m ago

And I've tried to log in using Thunderbird, with no success... keep getting an error that says "unable to login at server..."  even when I manually input the settings listed here:  https://www.xfinity.com/support/articles/setting-up-thunderbird?

Visitor

 • 

8 Messages

2 m ago

Any suggested fixes on this?  I've sent a DM to "Xfinity Support", as was suggested multiple times in a similar thread, but have yet to hear anything back.

Visitor

 • 

8 Messages

2 m ago

Just successfully logged into webmail...

New to the Community?

Start Here