grammie8's profile

Contributor

 • 

21 Messages

Sat, Jul 16, 2022 4:58 PM

Why do I have to enter a security code every time I log in to email?

Every time I log in to my comcast mail, I have to enter a security code sent via text.  Sometimes I have to enter the security code, re-enter my password, and then I get another security code.  Yes, I have clicked "not to ask again on this browser" and "stay logged in." 

Accepted Solution

Official Employee

 • 

474 Messages

2 m ago

Perfect! Thank you for letting me know those details. I apologize, for any confusion, as I was not clear you have looked at the setting suggested, either way, you are on it! If the app is working, that is good news, let us know if anything changes, we will be happy to engage. 👍

Official Employee

 • 

474 Messages

2 m ago

Hello. Thank you for reaching out for help with the Two-Step Verification. I have found this link very helpful in adjusting the settings, and turning off the verification. Also, try to clear your cache and cookies, and see if that helps after the first go around. -Brandon

grammie8

Contributor

 • 

21 Messages

@XfinityBrandon​ This was not helpful information as I already reviewed this before posting here.

"Will I have to enter a verification code every time I sign in?
Once you have enrolled in Two-Step Verification, you will be asked to enter a new verification code each time you sign in. However, you can choose to not require a code for future sign-ins from that particular device by checking the box labeled Don’t ask me again on this device."

That's not my experience at all.  Friday I had to get the code FOUR times in five minutes (and never signed out), and each time I clicked to not be asked again on this device.  I am in frustrating cycle of put in password, get code, put in code, get asked for password again, put in password, get code, put in code, get asked for password again, put in password . . . you get the idea.

Cache and cookies are cleared regularly.  Makes no difference.  Comcast has a problem with this feature and needs to fix it.  I see that I am not alone in this.  It only recently started for me although I see others have had the same situation months ago. Thank you for trying to help though.

I downloaded the authenticator app two days ago.  I no longer seem to be getting asked for a code.  We'll see how long that lasts.

forum icon

New to the Community?

Start Here