U

Visitor

 • 

2 Messages

Sunday, June 4th, 2023 4:36 PM

Closed

Unable to load my email

I can log in with 2-factor authorization.  But it doesn't work when I use the "Email" button from my.xfinity.com/?cid=cust.  I get redirected to connect.xfinity.com/appsuite where I briefly see "We are now loading your email."  Then I am redirected back to my.xfinity.com/?cid=cust

The same thing happens when I use the "Check Email" option under the "Account" button from www.xfinity.com/auth

I have cleared my browser cache/cookies and restarted.

Visitor

 • 

2 Messages

1 year ago

I tried sending email to myself from another account.  I got the following response.  Did my email account get closed?

Address not found: Your message wasn't delivered to [Edited: "Personal Information"] because the address couldn't be found, or is unable to receive mail.

The response from the remote server was:

550 5.1.1 Not our Customer

(edited)

Expert

 • 

30.6K Messages

@user_8015eb​ 

Are you a current Comcast customer?

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Please mark an Accepted Answer!tick

Official Employee

 • 

1K Messages

Hey there, are you currently a customer with us?

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick
forum icon

New to the Community?

Start Here