Brigid272's profile

Frequent Visitor

 • 

36 Messages

Sat, May 1, 2021 9:35 PM

Two factor authentication Problem

Recently (like the last two weeks), every time my husband logs into his Comcast email on his laptop, it asks for a passcode and sends one to his phone. He checks the box underneath that says Don’t ask me again on this device but when he logs in again later in the day the same thing happens and it won’t recognize the laptop. It’s been going on for about two weeks. It doesn’t happen when he checks email on his phone. It’s possible this is linked to the demise of the xfinity connect app on April   20. Any help for this? It’s a pain!

It’s not happening for me on my laptop, but I mostly use an iPad and sometimes my iPhone to connect to the webpage for email now. 

Responses

Official Employee

 • 

2.7K Messages

2 m ago

Hello, @Brigid272! Thanks for taking the time to reach out to us here on the Xfinity Forums! You've definitely come to the right place for help. I can imagine how frustrated you must be at this point, having to do two-factor authentication every single time does get a bit tedious and we look forward to helping you through this. 

 

Does your husband happen to use a VPN on his laptop?

Brigid272

Frequent Visitor

 • 

36 Messages

Nope. I’m the IT Dept.

Official Employee

 • 

201 Messages

Thanks for confirming that he isn't using a VPN, that's helpful information! What is the browser that he's using to sign in? Has he already tried clearing the cache and cookies? 

Regular Visitor

 • 

5 Messages

I have the exact same problem. I’m on Chrome with Win 10.

Official Employee

 • 

94 Messages

@PRgreen, I would be happy to help and look into your concern. send us a private message with your full name (and the account holder's name if different from you) and the numbers associated with your service address. To send a Private Message, please click on the chat icon in the top-right corner of the screen, next to the bell icon, and then type or select "Xfinity Support" to initiate a live chat.

Regular Visitor

 • 

5 Messages

I spoke with a comcast support person today. I'm still not sure she could understand the issue, but she did say that Comcast does NOT support Chrome. Is that right?

Also as an FYI - I tried Edge - the Edge browser does appear to recognize the "Don't ask on the browser again" option. It seems crazy for me to use Chrome for everything except Comcast. Makes no sense.

Again

Expert

 • 

25.8K Messages

2 m ago

@Brigid272 

I mentioned this before, on his laptop, make sure that cookies are set for connect.xfinity.com, otherwise checking that box won't have any effect.

Brigid272

Frequent Visitor

 • 

36 Messages

Um....okaayyy. Have never had to do that before. And it’s not doing it on my devices. If that doesn’t work, I’ll probably just turn off two-factor authentication because it’s a royal pain.

I will also have to figure out how to “set cookies” in Safari.

Brigid272

Frequent Visitor

 • 

36 Messages

1 m ago

Now I’m getting a message that I should accept one of these responses as a “solution”—but no solution has been suggested! Help!

Again

Expert

 • 

25.8K Messages

@Brigid272

It's a known forum glitch.  I get them, too.

New to the Community?

Start Here