jcgeneral's profile

Regular Visitor

 • 

6 Messages

Thu, Sep 24, 2020 4:00 PM

repeatedly asking for password

In the last day or so, every time I open my mail via Outlook, I'm constantly being prompted for my login credentials. This is a new problem and hasn't happened before.

 

Anybody know what the issue is?

Responses

Official Employee

 • 

96 Messages

8 m ago

@jcgeneral 

 

Hello,

 

I can confirm that there have been no password changes on your actual email recently.

 

This is usually a client setting in outlook. You should be able to check the prompt for password settings. You will want to make sure your settings in outlook are as intended for “Always prompt for logon credentials” section.

 

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

Regular Visitor

 • 

6 Messages

8 m ago

Checked account setting and all good.  Still asking for PW every time I open Outlook.  Sending outbox seems to be very slow as well.

 

It's not the end of the world to provide PW, just haven't had to do that for many years and now concerned it's a sign of a larger issue.

 

Please advise.

Latoque

Expert

 • 

28.8K Messages

8 m ago


@jcgeneral wrote:

Checked account setting and all good.  Still asking for PW every time I open Outlook.  Sending outbox seems to be very slow as well.

 

It's not the end of the world to provide PW, just haven't had to do that for many years and now concerned it's a sign of a larger issue.

 

Please advise.


See if the information here solves the issue for you.  Make sure you read the whole article--------------------

 

https://helpdeskgeek.com/office-tips/how-to-fix-outlook-keeps-asking-for-password-issue/

 

 

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

Visitor

 • 

1 Message

1 m ago

I am also having this issue and it appears to be an Xfinity mail issue because it happens on all my devices which all have different email apps installed. Even turned off authentication in Thunderbird as a test and when program is opened it asks for password immediately

EG

Expert

 • 

86.6K Messages

1 m ago

@user_1c4a0b 

Please create a new topic of your own here on this board detailing your issue. Thanks. 6 month old dead now being closed.

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New to the Community?

Start Here