Donnastar's profile

New Poster

 • 

1 Message

Thu, Oct 8, 2020 4:00 PM

Problem with email "from"

When I send an email, the receiver sees "COMCAST" in their inbox, rather than my email address. How do I change? (My preferred email is correct in account settings.)

Responses

Again

Expert

 • 

25.5K Messages

7 m ago


@Donnastar wrote:

When I send an email, the receiver sees "COMCAST" in their inbox, rather than my email address. How do I change? (My preferred email is correct in account settings.)


In webmail, star a new Compose mail.  In the From: line you should see a small arrow.  Click there and you will get a box that has the names of your email.  Choose the one you need to change and click on Edit names.  Input the name you want people to see when they receive your email.  Click on Save when you're done.

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New to the Community?

Start Here