U

Visitor

 • 

2 Messages

Sun, Jul 18, 2021 7:54 PM

Outgoing emails show they are from comcast and not my email address

Please fix this.  Settings have my name [EDIT:PI] but emails go to people from "Comcast" so nobody reads them.

Responses

BruceW

Gold Problem Solver

 • 

22.8K Messages

2 m ago

Please edit your post to remove your name. Posting personal information violates forum guidelines, see https://forums.xfinity.com/conversations/guidelines/xfinity-forum-acceptable-use-policy/602d9c64c5375f08cd574236. To edit your message go to the three vertical dots at the top right corner of the post, select Edit, make your changes, then click Post to save them.

If you are sending emails with Comcast's webmail ( https://connect.xfinity.com/ ), in a web browser on a desktop or laptop open a "Compose" window and

  1. Click the "From" address to open the drop-down
  2. Click "Edit names"
  3. In the "Edit real names" box, tick the checkbox
  4. Type the name you want to appear in "From"
  5. Click Save

If you don't have access to a desktop or laptop, you might be able to follow the steps above by using a web browser's "Desktop site" function on a mobile device.

 

If you are using an email program or app to send, what is its name and version? You'll need to check it's settings to correct the name on the From: line.

(edited)

New to the Community?

Start Here