prest1gtm's profile

New Poster

 • 

1 Message

Mon, Aug 10, 2020 10:00 AM

Mail sent to comcast recipients silently discarded (no error, not sent to spam/junk)?

Just started happening yesterday - email sent to recipients with @comcast.com domains are being silently discarded or not forwarded to recipients.  Sending domain's mail server is not on Comcast's network, was working fine for years until yesterday. 

 

No bounce, no error, sending mail server logs show the email was accepted by comcast. But recipients do not have it - not even in junk mail.   Sending domain and IP address are not on any known block lists and mail server security certificates/DKIM/etc are up to date.

 

Anyone else have this problem? 

Responses

Regular Visitor

 • 

4 Messages

8 m ago

Have had this exact problem since about 5 August.  Am using Outlook in Office 365 and have tried all sorts of different settings.  None solve the problem.

Again

Expert

 • 

25.3K Messages

8 m ago


@prest1gtm wrote:

Just started happening yesterday - email sent to recipients with @comcast.com domains are being silently discarded or not forwarded to recipients.  Sending domain's mail server is not on Comcast's network, was working fine for years until yesterday. 

 

No bounce, no error, sending mail server logs show the email was accepted by comcast. But recipients do not have it - not even in junk mail.   Sending domain and IP address are not on any known block lists and mail server security certificates/DKIM/etc are up to date.

 

Anyone else have this problem? 


Do you mean @comcast.net instead of @comcast.com?

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New to the Community?

Start Here