ranger26's profile

Regular Visitor

 • 

2 Messages

Tue, Jan 7, 2020 7:00 PM

Emails show as sent but not received

January 7, 2020. All of a sudden today I cannot send emails. They show up as sent but are not received.  I have tried my Mac, iPhone and iPad and it happens on all three.  It happens doing email directly in xfinity mail, outlook or with the Apple mail. Is Comcast having a problem or has something changed?  

Responses

BruceW

Gold Problem Solver

 • 

22.4K Messages

1 y ago

If @CCAntiSpam or another employee doesn't reply to your message here, Comcast Security Assurance should be able to help. You can reach them at 1-888-565-4329 (from https://internetsecurity.xfinity.com/help/report-abuse/). Note that this is NOT one of the general customer service numbers.

The first-line reps there are sometimes not very helpful, so you may need to be persistent and keep at them until you get a satisfactory answer.

CCAntiSpam

Bronze Problem Solver

 • 

1.9K Messages

1 y ago

@ranger26 Please try again in about 10 minutes.

Official Employee

 • 

97 Messages

6 m ago

@Glennyaeger  I am sending you a PM.

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New Poster

 • 

1 Message

6 m ago

Same problem . Please fix a

New to the Community?

Start Here