justme791's profile

Frequent Visitor

 • 

10 Messages

Sun, May 2, 2021 3:42 PM

Email 2 step verification - Why am I suddenly required to do this for email at home?

I have had 2 step verification turned on for years and it is a good feature. When I am away from my home network it prompts me to need to enter a verification code, but when I am at home, it does not. Until a few weeks ago. Now it requires this when I want to sign into my email at home, even though I keep checking the box "do not ask me again for this browser". So I had to turn it off, which I didn't want to do. Is this a problem others are having and is Xfinity aware of it and working on a fix?

Responses

Again

Expert

 • 

25.8K Messages

2 m ago

@justme791 

Make sure you have cookies set for connect.xfinity.com

justme791

Frequent Visitor

 • 

10 Messages

Cookies were set so I removed them, then logged back in and turned 2 step verification back on which re-established cookies (I checked). Will watch it over the next few days and let you know if the problem is resolved or returns. Thanks so much.

justme791

Frequent Visitor

 • 

10 Messages

So....unfortunately this was not the answer. It worked for the first 24 hours but now the problem is back. If I log into Xfinity email from my PC, I am prompted to enter a verification code that is sent to my phone. Other suggestions very welcome!

Official Employee

 • 

191 Messages

Hi, @justme791. I want to confirm a few things. This issue is on the same device and platform right? Such as our website on the same computer rather than going through different platforms to get to your email. If it is on a website making sure it's the same website browser as well, such as chrome, internet explorer etc each time on the same device accessing the same website for your email. 

 

I know this is a lot of things to confirm, but we like to narrow down any issues that could come up first and then dive deeper into the issue. Are you also using our athenticator app as well, or did you just set up the text/email code? 

Visitor

 • 

3 Messages

@Again A 

The answer to your questions are : I am using the same browser on the same device and platform and I have checked the box to not ask me again on this browser.  I have checked my cookies in Firefox and it looks like coolies are being set as they are not blocked and there is recent evidence of their acceptance by Comcast mail, Xfinity, etc

Frequent Visitor

 • 

7 Messages

1 m ago

Same problem on multiple devices, through Comcast Website, using Firefox and safari. Just started after travel, but now for 3 days after being home and checking, don’t require on this browser, I have to enter code EVERY time I log in. 

Regular Visitor

 • 

5 Messages

1 m ago

I have the same problem. Every day I'm asked to input a verification code when I log into my email.... always from the same PC, same browser (Chrome), and I ALWAYS check the box for "Don't ask on this device" again. This only occurs on a desktop PC.

And as an FYI, When I'm not in front of my PC, I use an email app on my phone and tablet, and those devices don't require a code when I check email.  

Visitor

 • 

3 Messages

1 m ago

I share this problem and it also arose fairly recently.  Does not recognize "Remember This Browser" feature.  Yes and it is every time I log in.  I can't even find a customer service phone number to talk to a live agent about this.

justme791

Frequent Visitor

 • 

10 Messages

1 m ago

@ComcastStarr - I can confirm all of the things you asked (same PC, same browser - Chrome) however I am not sure about this question you asked - "Are you also using our athenticator app as well, or did you just set up the text/email code?" I guess I'm not familiar with what the authenticator app is. I had set up 2 step verification on my PC (turned it off again because of this problem) and it uses the mobile # in my Xfinity profile.

It seems that this has become a common problem as @pgonly  , @venicenancy  and @PRgreen all have the same experience. Checking the "remember this browser" feature is useless and the problem doesn't occur on our mobile devices. I share the frustration of @pgonly that there is no actual customer service to call for an issue like this. We have to rely on the kindness of someone like you and chance that you'll stumble on our posts.

Official Employee

 • 

119 Messages

I appreciate you confirming that with me @justme791. I've done some further digging into this, and it does appear that the issue you and others described is due to an ongoing technical issue that is impacting some users enrolled in two-step verification. I'm truly sorry that you and everyone posting here have been going through this as of late, but our teams are working on implementing a fix to resolve this issue.

Visitor

 • 

1 Message

I am also having the same problem.  Customer service suggested that I clear browsing history and I also made sure that cookies enabled but did not help.   Any idea when the issue will be corrected?

Official Employee

 • 

257 Messages

Hello and thank you for taking the time to reach out to us here on our Xfinity Forums. I'm truly sorry for any frustration caused by the 2 step verification. Is this still occurring? If so can you clarify if it is happening on a mobile device or a PC?

New to the Community?

Start Here