robinengleberg's profile

Regular Visitor

 • 

2 Messages

Wed, Mar 4, 2020 12:00 PM

Draft folder emails

how do I open an email from my Draft folder so I can edit and send?

Responses

Again

Expert

 • 

25.8K Messages

1 y ago


@robinengleberg wrote:

how do I open an email from my Draft folder so I can edit and send?


Are you not able to click on the email in your Draft folder and have it open?  I just opened the Draft folder and clicked once on an email and it opened.  Once opened, just click on Edit under the To field.

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

Regular Visitor

 • 

2 Messages

1 y ago

the draft will not open.  I composed an email, saved it in the draft folder but did not put in an address.  I intend to do that later.  Could that be the problem?

Again

Expert

 • 

25.8K Messages

1 y ago


@robinengleberg wrote:

the draft will not open.  I composed an email, saved it in the draft folder but did not put in an address.  I intend to do that later.  Could that be the problem?


I could not replicate that.  Have you tried putting a check mark in the box next to the draft mail and then clicking on Edit draft on the tool bar?

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick
Latoque

Expert

 • 

28.8K Messages

1 y ago


@robinengleberg wrote:

the draft will not open.  I composed an email, saved it in the draft folder but did not put in an address.  I intend to do that later.  Could that be the problem?


Using Firefox, I'm having a bit of trouble with this too.  When I open the draft message and click on "Edit" the window opens but part of the top at the From line is kind of obscured.  But if I try the same thing using Edge or Vivaldi it works just fine.  Try using a different browser and see if it works that way.

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New to the Community?

Start Here