JayDC's profile

New Poster

 • 

4 Messages

Thu, Apr 15, 2021 10:16 PM

comcast email incompatible with Apple Mail

My main Comcast email account stopped working with Apple Mail yesterday. I can still access email on the web and two of my Comcast accounts still work with Apple Mail, but not the main one I use. I've spent many hours trying everything that I've read to solve the problem, plus hours on the phone with first one tech person from Xfinity and then another from Apple, all to no avail. I tried deleting my email account and setting it up again, but that didn't work either. I've tried resetting the ports as instructed but nothing has worked.

Responses

Latoque

Expert

 • 

28.8K Messages

21 d ago

I have 4 Comcast accounts enabled in Mac Mail and they all work OK for me.  Exactly what happens when you try to use the account in question in Mail?  Are you getting any error message?

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New Poster

 • 

4 Messages

20 d ago

I think it has something to do with the server. I can access my Comcast account on the webpage and I can send email from the account in Mail using a different server. I cannot receive email, however. I have two other Comcast addresses that work with Mac Mail. I've wasted a huge amount of time on this trying everything that has been suggested so far so I'm ready to give up. The email is forwarding to another address that works.

New Poster

 • 

4 Messages

19 d ago

I apparently fixed the problem. After trying many suggestions, I opened my email at connect.xfinity.com and clicked Email settings in the drop down menu under the icon that looks like a gear in the upper right hand corner. After clicking Security I noticed that the box under Third Party Access Security was unchecked. I checked the box to allow access to my Xfinity Connect email though third party programs. After re-adding my email account in Apple Mail I entered numbers for the ports (993 for the Incoming Mail Server and 465 for the Outgoing Mail Server) and I was able to receive and send email again. I don't know how the Third Party Access Security box became unchecked, however, since I never unchecked it. This was one of the more difficult problems with a computer that I seemed to fix and I know next to nothing about computer technology. The experts I consulted didn't figure it out.

Visitor

 • 

1 Message

Same problem, but when I open "security" to be sure the that third party access is check ... strange thing, the page open with the box unchecked but instantly gets checked. (Does this happen to you?) When I close SECURITY the box is still checked, but email still not uploaded to Apple Mail. 

Not sure what numbers for ports means. 

Official Employee

 • 

2.5K Messages

Hi, user_6eafe9. Thank you for your input here. I wanted to share a couple links with you: https://comca.st/3nPCKFo, https://comca.st/3xJe8Tv, and https://comca.st/2St3WOO. Which version of Apple Mail do you have and are you on a PC or mobile device?

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New to the Community?

Start Here