csdrbh's profile

New Poster


1 Message

Tue, Nov 3, 2020 4:00 PM

Comcast Email account (smtp) not sending when not on Comcast ISP Service

    I recently moved to Texas and sadly Comcast is not available, but I was told I could continue using my longtime Comcast email account.  However, I am unable to send any emails with my email client (Thunderbird) on my MacBook (I can pull email fine via IMAP).  I get the following error message when sending email via smtp.comcast.net port 465 :


An error occurred while sending mail: The mail server sent an incorrect greeting: resomta-ch2-15v.sys.comcast.net resomta-ch2-15v.sys.comcast.net CSI IP is not permitted to send messages. Please contact support if you feel this is in error..


If I use port 587 I get the following message:


Sending of the message failed.
The message could not be sent because the connection to Outgoing server (SMTP) smtp.comcast.net was lost in the middle of the transaction. Try again.


This problem actually started happening before I ever left Comcast.  When I travel in my RV I use an AT&T Cellular Modem for internet connection and I got the same error.  It appears that the only time my email client worked without any problems was only when I was at home on my Comcast ISP connection.


After doing more research, it appears that the filters in place at Comcast are blocking the ability to send any emails from cellular ISP connections.  


Here at my new home the only ISP service I can get is from NextLink which installs a dish at my house to receive/transmit data via RF to the tower.  My router IP address is, Default Gateway, Primary DNS, and Secondary DNS  My IP address is a Dynamic so it could change in the future.


All my other email accounts function fine with other providers (Gmail, Yahoo, my own web portal service, etc.) and my email client, just like it did when I was on the Comcast ISP service.


Can you please update your filters to allow the use of other ISP providers like cellular and RF towers?  Otherwise hanging on to Comcast as a provider is not going to be possible after 20 years!


RB Hooks


Regular Visitor


2 Messages

7 m ago

RB -- Had the same problem, but seem to have 'fixed' it.


With Thunderbird,  I just changed my "Outgoing Server" definition for smtp.comcast.net to use port 587 , and set it for STARTTLS instead of the "SSL/TLS" method for connection security.   I can now send from Thunderbird.






Gold Problem Solver


22.4K Messages

7 m ago

@csdrbh wrote: ... CSI IP is not permitted to send messages.

CSI in the error message means the listed IP is blocked by Cloudmark Sender Intelligence. is assigned to Nextlink Broadband (see https://whois.arin.net/rest/net/NET-52-144-96-0-1/pft?s= Please see https://forums.xfinity.com/t5/Email-Web-Browsing/Can-t-Send-Emails-from-PC-or-Phone-App/m-p/3355422#... for a discussion by @ComcastCSAEmail of how Comcast uses CSI, although concerning a different ISP in that case.


Are you using a VPN or a non-Comcast ISP?


New to the Community?

Start Here