storby's profile

Regular Visitor

 • 

3 Messages

Tue, Dec 15, 2020 7:00 AM

Can't turn off spam filter

Last week email from my family members and other legitimate sources started being re-directed to the spam folder therfore never showing up in Outlook. I have marked them as not spam and turned off the spam filtering which has no affect. I need xfinity to quit making assumptions on what email I want to see. I can manage my own email! How can I make it stop?

Responses

Accepted Solution

storby

Regular Visitor

 • 

3 Messages

6 m ago

Solved:

 

There was a computer that was supposed to be disconnected but wasn't that had Junk mail filter setup in Outlook. Since it had an IMAP connection it was directly affecting the comcasr mailbox. Turned off Outlook and the problem stopped

Latoque

Expert

 • 

28.8K Messages

6 m ago

Try putting the senders in your address book.  See here-----------------

 

https://forums.xfinity.com/t5/Email-Web-Browsing/Address-Book-Exemption/m-p/3368877#M220644

storby

Regular Visitor

 • 

3 Messages

6 m ago

I tried that and it fixed some of the emails but there are some that it refuses to keep in the inbox. You set it as "not spam" and it goes into the inbox for about 10 seconds and then goes right back to the spam folder. 

 

The ironic thing is that one of the senders that is giving me problems is my wife who uses a comcast email account attached to my account.

 

I have the email option "override security filters" turned on which is supposed to not filter anything but appears to not work.

 

 

New to the Community?

Start Here