PA_WOODCHUCK's profile
PA_WOODCHUCK
Expressive Exchange
Responsive
Conversation Starter

Contributor

 • 

28 Messages

Fri, Dec 25, 2020 11:00 AM

Brower pages loading slowly over past months

Been getting slower recently, loads slower, fails to load, or site not found. My speedtest is over 600Mbps+ daily.

 

windows 10 with all updates.

MS edge and firefox

Same with 2 other PC's on network

1 WiFi and 2 cable connection

 

thanks

Responses

Again

Expert

 • 

25.5K Messages

5 m ago


@PA_WOODCHUCK wrote:

Been getting slower recently, loads slower, fails to load, or site not found. My speedtest is over 600Mbps+ daily.

 

windows 10 with all updates.

MS edge and firefox

Same with 2 other PC's on network

1 WiFi and 2 cable connection

 

thanks


Clear your browser cache.

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

Contributor

 • 

28 Messages

4 m ago

Thanks for the responce

 

4 are pre checked, cookies, browsing history, download history, cached images

Sould I clear them all, and will auto login to sites w/passwords remain active, including auto fill?

Again

Expert

 • 

25.5K Messages

4 m ago


@PA_WOODCHUCK wrote:

Thanks for the responce

 

4 are pre checked, cookies, browsing history, download history, cached images

Sould I clear them all, and will auto login to sites w/passwords remain active, including auto fill?


Leave your cookies, otherwise you'll lose all your auto logins/saved passwords.

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

Contributor

 • 

28 Messages

4 m ago

Tried all that with no improvement. Also noticed on my home WiFi that my Ipad/Iphone have same issue... so going to contact xfinity support next week.

Official Employee

 • 

296 Messages

4 m ago

Hi there, @PA_WOODCHUCK. I know slow speeds can really hinder your online experience. I'm sorry your browser is loading more slowly. Since this can happen for so many reasons feel free to select my name and use the send private message option to provide your name and service address. We can check your service and signal quality this way! Another thing you can do is double-check the number of devices you have on your network. 

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

Contributor

 • 

28 Messages

4 m ago

I did message week or so ago, but haven't got an answer yet.

ComcastChe

Official Employee

 • 

6.1K Messages

3 m ago

Hi @PA_WOODCHUCK, We appreciate your patience! I was able to locate your private messages and am happy to see you were finally able to chat with an agent. I'll be replying shortly so we can begin troubleshooting. We will keep this public thread open until we can confirm this slow browsing is no longer an issue. Chat with you soon! 

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New to the Community?

Start Here